aboutsummaryrefslogtreecommitdiff
path: root/fontconfig/configure.ac
diff options
context:
space:
mode:
authormarha <marha@users.sourceforge.net>2013-06-28 16:47:15 +0200
committermarha <marha@users.sourceforge.net>2013-06-28 16:47:15 +0200
commitced1a6b8f5a750fcd3b8d3d0d9bbdee830064e6c (patch)
tree24d79f7eaee4d69dde46cf88aa7314a4fceebbe5 /fontconfig/configure.ac
parent2fe2056807d1304de86deb2b59992d51d9252ad0 (diff)
downloadvcxsrv-ced1a6b8f5a750fcd3b8d3d0d9bbdee830064e6c.tar.gz
vcxsrv-ced1a6b8f5a750fcd3b8d3d0d9bbdee830064e6c.tar.bz2
vcxsrv-ced1a6b8f5a750fcd3b8d3d0d9bbdee830064e6c.zip
fontconfig mesa git update 28 June 2013
fontconfig commit 197d06c49b01413303f2c92130594daa4fcaa6ad mesa commit 24b05ff1581b612ab6dbf4937fa4b644b4e61379
Diffstat (limited to 'fontconfig/configure.ac')
-rw-r--r--fontconfig/configure.ac29
1 files changed, 29 insertions, 0 deletions
diff --git a/fontconfig/configure.ac b/fontconfig/configure.ac
index 0f129db0d..a2b1c72f4 100644
--- a/fontconfig/configure.ac
+++ b/fontconfig/configure.ac
@@ -161,6 +161,35 @@ AC_LINK_IFELSE([AC_LANG_SOURCE([[
AC_MSG_RESULT([yes])
AC_DEFINE([HAVE_POSIX_FADVISE], [1], [Define to 1 if you have the 'posix_fadvise' function.])
],[AC_MSG_RESULT([no])])
+AC_MSG_CHECKING([for scandir])
+AC_LINK_IFELSE([AC_LANG_SOURCE([[
+ #include <dirent.h>
+ int comp(const struct dirent **, const struct dirent **);
+ int comp(const struct dirent **a, const struct dirent **b) { return 0; }
+ int main(void) {
+ struct dirent **d;
+ return scandir(".", &d, 0, &comp) >= 0;
+ }
+ ]])],[
+ AC_MSG_RESULT([yes])
+ AC_DEFINE([HAVE_SCANDIR], [1], [Define to 1 if you have the 'scandir' function.])
+ ],[
+ AC_LINK_IFELSE([AC_LANG_SOURCE([[
+ #include <dirent.h>
+ int comp(const void *, const void *);
+ int comp(const void *a, const void *b) { return 0; }
+ int main(void) {
+ struct dirent **d;
+ return scandir(".", &d, 0, &comp) >= 0;
+ }
+ ]])],[
+ AC_MSG_RESULT([yes])
+ AC_DEFINE([HAVE_SCANDIR_VOID_P], [1], [Define to 1 if you have the 'scandir' function with int (* compar)(const void *, const void *)])
+ ],[
+ AC_MSG_ERROR([
+*** No scandir function available.])
+ ])
+ ])
CFLAGS="$fc_saved_CFLAGS"
#