aboutsummaryrefslogtreecommitdiff
path: root/fontconfig/test/Makefile.am
diff options
context:
space:
mode:
authormarha <marha@users.sourceforge.net>2013-01-11 08:00:45 +0100
committermarha <marha@users.sourceforge.net>2013-01-11 08:00:45 +0100
commitddc05759f098f06bd93253a7bffe38640963dfb3 (patch)
treefd0ae943233033cda2bfe50dd097532a4cf5c0b9 /fontconfig/test/Makefile.am
parent8a26872f0c9102cb357345eca24a4bf7401bbe70 (diff)
downloadvcxsrv-ddc05759f098f06bd93253a7bffe38640963dfb3.tar.gz
vcxsrv-ddc05759f098f06bd93253a7bffe38640963dfb3.tar.bz2
vcxsrv-ddc05759f098f06bd93253a7bffe38640963dfb3.zip
fontconfig libX11 mesa mkfontscale xserver git update 11 jan 2013
fontconfig: 0831c1770e4bac7269a190936bbb0529d747e233 libX11: 0b148750027fd0557c5ed93afda861ddf4b92e0f mkfontscale: 9cbe3256bc932b82f2435b23cda0931f4f5f5ba2 xserver: 6703a7c7cf1a349c137e247a0c8eb462ff7b07be mesa: babab2876080af0fe65249dff559244aebd0b87e
Diffstat (limited to 'fontconfig/test/Makefile.am')
-rw-r--r--fontconfig/test/Makefile.am11
1 files changed, 11 insertions, 0 deletions
diff --git a/fontconfig/test/Makefile.am b/fontconfig/test/Makefile.am
index 3fd343a24..664138a5b 100644
--- a/fontconfig/test/Makefile.am
+++ b/fontconfig/test/Makefile.am
@@ -4,6 +4,17 @@ TESTS=run-test.sh
TESTDATA=4x6.pcf 8x16.pcf out.expected fonts.conf.in
+AM_CPPFLAGS = -I$(top_srcdir) -I$(top_builddir)
+
+if HAVE_PTHREAD
+check_PROGRAMS = test-pthread
+noinst_PROGRAMS = $(check_PROGRAMS)
+test_pthread_LDADD = $(top_builddir)/src/libfontconfig.la
+# We don't enable this test by default because it will require config and fonts
+# to meaningfully test anything, and we are not installed yet.
+#TESTS += test-pthread
+endif
+
EXTRA_DIST=$(check_SCRIPTS) $(TESTDATA)
CLEANFILES=