aboutsummaryrefslogtreecommitdiff
path: root/libX11/configure.ac
diff options
context:
space:
mode:
authormarha <marha@users.sourceforge.net>2009-10-29 18:29:39 +0000
committermarha <marha@users.sourceforge.net>2009-10-29 18:29:39 +0000
commita5709eca77ddfd18c5f915d8b71f46abc3246279 (patch)
tree165b825df7b0a0b5843835c0d0484076f95f572a /libX11/configure.ac
parent1f876171067c04fc21fccd5a3051f982fd85c0f0 (diff)
downloadvcxsrv-a5709eca77ddfd18c5f915d8b71f46abc3246279.tar.gz
vcxsrv-a5709eca77ddfd18c5f915d8b71f46abc3246279.tar.bz2
vcxsrv-a5709eca77ddfd18c5f915d8b71f46abc3246279.zip
Updated to libX11-1.3.2
Diffstat (limited to 'libX11/configure.ac')
-rw-r--r--libX11/configure.ac16
1 files changed, 15 insertions, 1 deletions
diff --git a/libX11/configure.ac b/libX11/configure.ac
index db83f262a..d62269747 100644
--- a/libX11/configure.ac
+++ b/libX11/configure.ac
@@ -3,7 +3,7 @@
AC_PREREQ(2.60)
AC_INIT([libX11],
- 1.3.1,
+ 1.3.2,
[https://bugs.freedesktop.org/enter_bug.cgi?product=xorg],
libX11)
AC_CONFIG_SRCDIR([Makefile.am])
@@ -429,9 +429,23 @@ AC_DEFINE_DIR(XERRORDB, XERRORDB, [Location of error message database])
XORG_CHECK_MALLOC_ZERO
# Specification documents are currently provided in troff format
+AC_ARG_VAR([GROFF], [Path to a groff executable that supports -ms])
AC_PATH_PROGS([GROFF], [groff], [none], [$PATH:/usr/gnu/bin])
+
+AC_ARG_VAR([PS2PDF], [Path to a ps2pdf executable])
AC_PATH_PROGS([PS2PDF], [ps2pdf], [none], [$PATH:/usr/gnu/bin])
+if test "x${GROFF}" != xnone ; then
+ AC_MSG_CHECKING([whether ${GROFF} -ms works])
+ if ${GROFF} -ms -I. /dev/null >/dev/null 2>&1 ; then
+ groff_ms_works=yes
+ else
+ groff_ms_works=no
+ GROFF=none
+ fi
+ AC_MSG_RESULT([${groff_ms_works}])
+fi
+
AC_MSG_CHECKING([whether to build specifications])
AC_ARG_ENABLE(specs, AC_HELP_STRING([--enable-specs],
[Enable building of specification docs]),