aboutsummaryrefslogtreecommitdiff
path: root/libXaw/configure.ac
diff options
context:
space:
mode:
authormarha <marha@users.sourceforge.net>2012-04-10 14:58:33 +0200
committermarha <marha@users.sourceforge.net>2012-04-10 14:58:33 +0200
commit5f8448ef6b85a9ff72c5af4cec99183c8bb60dc6 (patch)
treec10939819ba1167cdc905a0c105c7ae4091abbc3 /libXaw/configure.ac
parent67326634496ef21b4acbf4cef2f05040d34aef9b (diff)
downloadvcxsrv-5f8448ef6b85a9ff72c5af4cec99183c8bb60dc6.tar.gz
vcxsrv-5f8448ef6b85a9ff72c5af4cec99183c8bb60dc6.tar.bz2
vcxsrv-5f8448ef6b85a9ff72c5af4cec99183c8bb60dc6.zip
Updated following packages:
bigreqsproto-1.1.2 fontsproto-2.1.2 recordproto-1.14.2 scrnsaverproto-1.2.2 xcmiscproto-1.2.2 libXt-1.1.3 xhost-1.0.5 kbproto-1.0.6 libXrender-0.9.7 libxkbfile-1.0.8 freetype-2.4.9 libXaw-1.0.10 libXpm-3.5.10 xproto-7.0.23
Diffstat (limited to 'libXaw/configure.ac')
-rw-r--r--libXaw/configure.ac29
1 files changed, 16 insertions, 13 deletions
diff --git a/libXaw/configure.ac b/libXaw/configure.ac
index 9c99e0366..24232638e 100644
--- a/libXaw/configure.ac
+++ b/libXaw/configure.ac
@@ -1,8 +1,7 @@
-dnl Process this file with autoconf to create configure.
# Initialize Autoconf
AC_PREREQ([2.60])
-AC_INIT([libXaw], [1.0.9],
+AC_INIT([libXaw], [1.0.10],
[https://bugs.freedesktop.org/enter_bug.cgi?product=xorg], [libXaw])
AC_CONFIG_SRCDIR([Makefile.am])
AC_CONFIG_HEADERS([config.h])
@@ -11,21 +10,26 @@ AC_CONFIG_HEADERS([config.h])
AM_INIT_AUTOMAKE([foreign dist-bzip2])
AM_MAINTAINER_MODE
-# Require xorg-macros minimum of 1.10 for HAVE_STYLESHEETS in XORG_CHECK_SGML_DOCTOOLS
+# Initialize libtool
+AC_PROG_LIBTOOL
+
+# Require xorg-macros minimum of 1.12 for DocBook external references
m4_ifndef([XORG_MACROS_VERSION],
- [m4_fatal([must install xorg-macros 1.10 or later before running autoconf/autogen])])
-XORG_MACROS_VERSION(1.10)
+ [m4_fatal([must install xorg-macros 1.12 or later before running autoconf/autogen])])
+XORG_MACROS_VERSION(1.12)
XORG_DEFAULT_OPTIONS
XORG_ENABLE_SPECS
-XORG_WITH_XMLTO(0.0.20)
+XORG_WITH_XMLTO(0.0.22)
XORG_WITH_FOP
-XORG_CHECK_SGML_DOCTOOLS(1.5)
+XORG_WITH_XSLTPROC
+XORG_CHECK_SGML_DOCTOOLS(1.8)
-# Check for progs
-AC_PROG_LIBTOOL
-AC_PROG_AWK
+# Some compilers do not support per target -c and -o flags
AM_PROG_CC_C_O
+# Checks for programs.
+AC_PROG_AWK
+
# Need to call this explicitly since the first call to PKG_CHECK_MODULES
# is in an if statement, and later calls would break if it's skipped.
PKG_PROG_PKG_CONFIG
@@ -65,7 +69,7 @@ AM_CONDITIONAL(PLATFORM_DARWIN, test "x$platform_darwin" = "xyes")
# Whether to build Xaw6
-AC_ARG_ENABLE(xaw6, AC_HELP_STRING([--disable-xaw6],
+AC_ARG_ENABLE(xaw6, AS_HELP_STRING([--disable-xaw6],
[Disable building of libXaw.so.6]),
[build_v6=$enableval], [build_v6=yes])
@@ -76,7 +80,7 @@ fi
# Whether to build Xaw7
-AC_ARG_ENABLE(xaw7, AC_HELP_STRING([--disable-xaw7],
+AC_ARG_ENABLE(xaw7, AS_HELP_STRING([--disable-xaw7],
[Disable building of libXaw.so.7]),
[build_v7=$enableval], [build_v7=yes])
@@ -89,7 +93,6 @@ AM_CONDITIONAL(BUILD_XAW6, [test x$build_v6 = xyes])
AM_CONDITIONAL(BUILD_XAW7, [test x$build_v7 = xyes])
# Checks for header files.
-AC_HEADER_STDC
AC_CHECK_HEADERS([wctype.h wchar.h widec.h])
# Checks for functions