aboutsummaryrefslogtreecommitdiff
path: root/libXinerama/configure.ac
diff options
context:
space:
mode:
authormarha <marha@users.sourceforge.net>2009-09-15 10:51:43 +0000
committermarha <marha@users.sourceforge.net>2009-09-15 10:51:43 +0000
commit4db64b701ca08687df5932321d48f2ef29b99fed (patch)
tree3a292398d6d29ab30de5e72284d09fdd4f87d934 /libXinerama/configure.ac
parentbbccfba902806cae541a20038a6e66308f0618b1 (diff)
downloadvcxsrv-4db64b701ca08687df5932321d48f2ef29b99fed.tar.gz
vcxsrv-4db64b701ca08687df5932321d48f2ef29b99fed.tar.bz2
vcxsrv-4db64b701ca08687df5932321d48f2ef29b99fed.zip
Added libXinerama-1.0.99.1
Diffstat (limited to 'libXinerama/configure.ac')
-rw-r--r--libXinerama/configure.ac57
1 files changed, 57 insertions, 0 deletions
diff --git a/libXinerama/configure.ac b/libXinerama/configure.ac
new file mode 100644
index 000000000..cf7fc80d8
--- /dev/null
+++ b/libXinerama/configure.ac
@@ -0,0 +1,57 @@
+dnl Copyright 2005 Red Hat, Inc.
+dnl
+dnl Permission to use, copy, modify, distribute, and sell this software and its
+dnl documentation for any purpose is hereby granted without fee, provided that
+dnl the above copyright notice appear in all copies and that both that
+dnl copyright notice and this permission notice appear in supporting
+dnl documentation, and that the name of Red Hat not be used in
+dnl advertising or publicity pertaining to distribution of the software without
+dnl specific, written prior permission. Red Hat makes no
+dnl representations about the suitability of this software for any purpose. It
+dnl is provided "as is" without express or implied warranty.
+dnl
+dnl RED HAT DISCLAIMS ALL WARRANTIES WITH REGARD TO THIS SOFTWARE,
+dnl INCLUDING ALL IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS, IN NO
+dnl EVENT SHALL RED HAT BE LIABLE FOR ANY SPECIAL, INDIRECT OR
+dnl CONSEQUENTIAL DAMAGES OR ANY DAMAGES WHATSOEVER RESULTING FROM LOSS OF USE,
+dnl DATA OR PROFITS, WHETHER IN AN ACTION OF CONTRACT, NEGLIGENCE OR OTHER
+dnl TORTIOUS ACTION, ARISING OUT OF OR IN CONNECTION WITH THE USE OR
+dnl PERFORMANCE OF THIS SOFTWARE.
+dnl
+dnl Process this file with autoconf to create configure.
+
+AC_PREREQ([2.57])
+
+AC_INIT(libXinerama, 1.0.99.1, [https://bugs.freedesktop.org/enter_bug.cgi?product=xorg], libXinerama)
+AM_INIT_AUTOMAKE([dist-bzip2])
+AM_MAINTAINER_MODE
+
+# Require xorg-macros: XORG_CWARNFLAGS, XORG_CHANGELOG, XORG_WITH_LINT
+m4_ifndef([XORG_MACROS_VERSION], [AC_FATAL([must install xorg-macros 1.2 or later before running autoconf/autogen])])
+XORG_MACROS_VERSION(1.2)
+AM_CONFIG_HEADER(config.h)
+
+# Check for progs
+AC_PROG_CC
+AC_PROG_LIBTOOL
+XORG_CWARNFLAGS
+
+# Check for dependencies
+PKG_CHECK_MODULES(XINERAMA, x11 xext xextproto [xineramaproto >= 1.1.99.1])
+XINERAMA_CFLAGS="$CWARNFLAGS $XINERAMA_CFLAGS"
+AC_SUBST(XINERAMA_CFLAGS)
+AC_SUBST(XINERAMA_LIBS)
+
+dnl Allow checking code with lint, sparse, etc.
+XORG_WITH_LINT
+LINT_FLAGS="${LINT_FLAGS} ${XINERAMA_CFLAGS}"
+
+XORG_CHECK_MALLOC_ZERO
+XORG_MANPAGE_SECTIONS
+XORG_RELEASE_VERSION
+XORG_CHANGELOG
+
+AC_OUTPUT([Makefile
+ src/Makefile
+ man/Makefile
+ xinerama.pc])