aboutsummaryrefslogtreecommitdiff
path: root/mesalib/configure.ac
diff options
context:
space:
mode:
authormarha <marha@users.sourceforge.net>2013-10-24 08:10:01 +0200
committermarha <marha@users.sourceforge.net>2013-10-24 08:10:01 +0200
commit4eb0b643ad978d94837e2d587a5d4358f974a25c (patch)
treeecb04ee3cf0d7c2fa80707218382d68e7a49f621 /mesalib/configure.ac
parent6d895f30ab93d71afddc612d8b007f2de7f04165 (diff)
downloadvcxsrv-4eb0b643ad978d94837e2d587a5d4358f974a25c.tar.gz
vcxsrv-4eb0b643ad978d94837e2d587a5d4358f974a25c.tar.bz2
vcxsrv-4eb0b643ad978d94837e2d587a5d4358f974a25c.zip
fontconfig mesa xserver git update 24 oct 2013
xserver commit 7ecfab47eb221dbb996ea6c033348b8eceaeb893 fontconfig commit 76ea9af816a50c6bb0b3dc2960460a90fadd9cdb mesa commit a6e45b6a17462f4d261a2d176791469847356923
Diffstat (limited to 'mesalib/configure.ac')
-rw-r--r--mesalib/configure.ac18
1 files changed, 16 insertions, 2 deletions
diff --git a/mesalib/configure.ac b/mesalib/configure.ac
index 08344c501..dfa35b41b 100644
--- a/mesalib/configure.ac
+++ b/mesalib/configure.ac
@@ -593,6 +593,12 @@ AC_ARG_ENABLE([opencl],
@<:@default=no@:>@])],
[],
[enable_opencl=no])
+AC_ARG_ENABLE([opencl_icd],
+ [AS_HELP_STRING([--enable-opencl-icd],
+ [Build an OpenCL ICD library to be loaded by an ICD implementation
+ @<:@default=no@:>@])],
+ [enable_opencl_icd="$enableval"],
+ [enable_opencl_icd=no])
AC_ARG_ENABLE([xlib-glx],
[AS_HELP_STRING([--enable-xlib-glx],
[make GLX library Xlib-based instead of DRI-based @<:@default=disabled@:>@])],
@@ -1337,8 +1343,8 @@ if test "x$enable_opencl" = xyes; then
AC_MSG_ERROR([cannot enable OpenCL without Gallium])
fi
- if test $GCC_VERSION_MAJOR -lt 4 -o $GCC_VERSION_MAJOR -eq 4 -a $GCC_VERSION_MINOR -lt 6; then
- AC_MSG_ERROR([gcc >= 4.6 is required to build clover])
+ if test $GCC_VERSION_MAJOR -lt 4 -o $GCC_VERSION_MAJOR -eq 4 -a $GCC_VERSION_MINOR -lt 7; then
+ AC_MSG_ERROR([gcc >= 4.7 is required to build clover])
fi
if test "x$have_libclc" = xno; then
@@ -1356,8 +1362,16 @@ if test "x$enable_opencl" = xyes; then
GALLIUM_STATE_TRACKERS_DIRS="$GALLIUM_STATE_TRACKERS_DIRS clover"
GALLIUM_TARGET_DIRS="$GALLIUM_TARGET_DIRS opencl"
enable_gallium_loader=yes
+
+ if test "x$enable_opencl_icd" = xyes; then
+ OPENCL_LIBNAME="MesaOpenCL"
+ else
+ OPENCL_LIBNAME="OpenCL"
+ fi
fi
AM_CONDITIONAL(HAVE_CLOVER, test "x$enable_opencl" = xyes)
+AM_CONDITIONAL(HAVE_CLOVER_ICD, test "x$enable_opencl_icd" = xyes)
+AC_SUBST([OPENCL_LIBNAME])
dnl
dnl Gallium configuration