aboutsummaryrefslogtreecommitdiff
path: root/mesalib/configure.ac
diff options
context:
space:
mode:
authormarha <marha@users.sourceforge.net>2014-05-29 20:46:21 +0200
committermarha <marha@users.sourceforge.net>2014-05-29 20:46:21 +0200
commit816a5430313e07083c5325f0a430126a2e10ec41 (patch)
tree82e47992f52149b83238690062e0c56202cb2ebb /mesalib/configure.ac
parentc2dfa0e8c98b06e050c530d704d75a7e4edad02e (diff)
downloadvcxsrv-816a5430313e07083c5325f0a430126a2e10ec41.tar.gz
vcxsrv-816a5430313e07083c5325f0a430126a2e10ec41.tar.bz2
vcxsrv-816a5430313e07083c5325f0a430126a2e10ec41.zip
mesa xkeyboard-config git update 29 Mar 2014
xkeyboard-config commit bc3ac1b0d152e929b3532a541596cf9fe286bb9e mesa commit dfd117b8570a69a429e660c069997e78b181ab6d
Diffstat (limited to 'mesalib/configure.ac')
-rw-r--r--mesalib/configure.ac7
1 files changed, 7 insertions, 0 deletions
diff --git a/mesalib/configure.ac b/mesalib/configure.ac
index 7397341b2..bee85a131 100644
--- a/mesalib/configure.ac
+++ b/mesalib/configure.ac
@@ -1728,6 +1728,13 @@ if test "x$enable_gallium_llvm" = xyes; then
if $LLVM_CONFIG --components | grep -qw 'option'; then
LLVM_COMPONENTS="${LLVM_COMPONENTS} option"
fi
+ # Current OpenCL/Clover and LLVM 3.5 require ObjCARCOpts and ProfileData
+ if $LLVM_CONFIG --components | grep -qw 'objcarcopts'; then
+ LLVM_COMPONENTS="${LLVM_COMPONENTS} objcarcopts"
+ fi
+ if $LLVM_CONFIG --components | grep -qw 'profiledata'; then
+ LLVM_COMPONENTS="${LLVM_COMPONENTS} profiledata"
+ fi
fi
DEFINES="${DEFINES} -DHAVE_LLVM=0x0$LLVM_VERSION_INT -DLLVM_VERSION_PATCH=$LLVM_VERSION_PATCH"
MESA_LLVM=1