aboutsummaryrefslogtreecommitdiff
path: root/mesalib/configure.ac
diff options
context:
space:
mode:
authormarha <marha@users.sourceforge.net>2013-09-10 09:01:25 +0200
committermarha <marha@users.sourceforge.net>2013-09-10 09:01:25 +0200
commit889d7dd8e94a5538f388cc619115bf5c0b6fc0b7 (patch)
treebdda17693281525be9d48886acf2dc89ac4c66b4 /mesalib/configure.ac
parent2414a1de3cc17f438219f8f2a58b530d33e99a5e (diff)
downloadvcxsrv-889d7dd8e94a5538f388cc619115bf5c0b6fc0b7.tar.gz
vcxsrv-889d7dd8e94a5538f388cc619115bf5c0b6fc0b7.tar.bz2
vcxsrv-889d7dd8e94a5538f388cc619115bf5c0b6fc0b7.zip
fontconfig libX11 libXmu libxcb mesa xserver git update 10 Sep 2013
xserver commit 47ff382d1fce25a8b097d45b79489e891f1f1228 libxcb commit f1405d9fe4a6ddcae24585ba254389a4c4f4c8c9 libX11 commit cb107760df33ffc8630677e66e2e50aa37950a5c libXmu commit 2539e539eafdac88177c8ee30b043c5d52f017e4 fontconfig commit a61e145304da86c8c35b137493bbd8fd5dd1e7f5 mesa commit 395b9410860371a64d6b5f2d50679f29eb41729e
Diffstat (limited to 'mesalib/configure.ac')
-rw-r--r--mesalib/configure.ac32
1 files changed, 0 insertions, 32 deletions
diff --git a/mesalib/configure.ac b/mesalib/configure.ac
index b19ab189e..7731a9973 100644
--- a/mesalib/configure.ac
+++ b/mesalib/configure.ac
@@ -45,9 +45,7 @@ LIBKMS_XORG_REQUIRED=1.0.0
dnl Check for progs
AC_PROG_CPP
AC_PROG_CC
-AX_PROG_CC_FOR_BUILD
AC_PROG_CXX
-AX_PROG_CXX_FOR_BUILD
AM_PROG_CC_C_O
AM_PROG_AS
AC_CHECK_PROGS([MAKE], [gmake make])
@@ -142,21 +140,6 @@ dnl Cache LDFLAGS and CPPFLAGS so we can add to them and restore later
_SAVE_LDFLAGS="$LDFLAGS"
_SAVE_CPPFLAGS="$CPPFLAGS"
-dnl build host compiler macros
-DEFINES_FOR_BUILD=""
-AC_SUBST([DEFINES_FOR_BUILD])
-case "$build_os" in
-linux*|*-gnu*|gnu*)
- DEFINES_FOR_BUILD="$DEFINES_FOR_BUILD -D_GNU_SOURCE"
- ;;
-solaris*)
- DEFINES_FOR_BUILD="$DEFINES_FOR_BUILD -DSVR4"
- ;;
-cygwin*)
- DEFINES_FOR_BUILD="$DEFINES_FOR_BUILD"
- ;;
-esac
-
dnl Compiler macros
DEFINES=""
AC_SUBST([DEFINES])
@@ -179,7 +162,6 @@ if test "x$GCC" = xyes; then
CFLAGS="$CFLAGS -Wall -std=gnu99"
;;
*)
- CFLAGS_FOR_BUILD="$CFLAGS_FOR_BUILD -Wall -std=c99"
CFLAGS="$CFLAGS -Wall -std=c99"
;;
esac
@@ -209,16 +191,13 @@ if test "x$GCC" = xyes; then
CFLAGS=$save_CFLAGS
# Work around aliasing bugs - developers should comment this out
- CFLAGS_FOR_BUILD="$CFLAGS_FOR_BUILD -fno-strict-aliasing"
CFLAGS="$CFLAGS -fno-strict-aliasing"
# gcc's builtin memcmp is slower than glibc's
# http://gcc.gnu.org/bugzilla/show_bug.cgi?id=43052
- CFLAGS_FOR_BUILD="$CFLAGS_FOR_BUILD -fno-builtin-memcmp"
CFLAGS="$CFLAGS -fno-builtin-memcmp"
fi
if test "x$GXX" = xyes; then
- CXXFLAGS_FOR_BUILD="$CXXFLAGS_FOR_BUILD -Wall"
CXXFLAGS="$CXXFLAGS -Wall"
# Enable -fvisibility=hidden if using a gcc that supports it
@@ -235,12 +214,10 @@ if test "x$GXX" = xyes; then
CXXFLAGS=$save_CXXFLAGS
# Work around aliasing bugs - developers should comment this out
- CXXFLAGS_FOR_BUILD="$CXXFLAGS_FOR_BUILD -fno-strict-aliasing"
CXXFLAGS="$CXXFLAGS -fno-strict-aliasing"
# gcc's builtin memcmp is slower than glibc's
# http://gcc.gnu.org/bugzilla/show_bug.cgi?id=43052
- CXXFLAGS_FOR_BUILD="$CXXFLAGS_FOR_BUILD -fno-builtin-memcmp"
CXXFLAGS="$CXXFLAGS -fno-builtin-memcmp"
fi
@@ -315,14 +292,6 @@ AC_ARG_ENABLE([debug],
[enable_debug=no]
)
if test "x$enable_debug" = xyes; then
- DEFINES_FOR_BUILD="$DEFINES_FOR_BUILD -DDEBUG"
- if test "x$GCC_FOR_BUILD" = xyes; then
- CFLAGS_FOR_BUILD="$CFLAGS_FOR_BUILD -g -O0"
- fi
- if test "x$GXX_FOR_BUILD" = xyes; then
- CXXFLAGS_FOR_BUILD="$CXXFLAGS_FOR_BUILD -g -O0"
- fi
-
DEFINES="$DEFINES -DDEBUG"
if test "x$GCC" = xyes; then
CFLAGS="$CFLAGS -g -O0"
@@ -2103,7 +2072,6 @@ AC_CONFIG_FILES([Makefile
src/gbm/Makefile
src/gbm/main/gbm.pc
src/glsl/Makefile
- src/glsl/builtin_compiler/Makefile
src/glx/Makefile
src/glx/tests/Makefile
src/gtest/Makefile