aboutsummaryrefslogtreecommitdiff
path: root/mesalib/configure.ac
diff options
context:
space:
mode:
authormarha <marha@users.sourceforge.net>2013-03-06 08:37:36 +0100
committermarha <marha@users.sourceforge.net>2013-04-11 11:13:32 +0200
commitfb84fb26466262dcab4bd31bdf51c982f14f891a (patch)
tree8b53ac928f676a2a6f2273c770d65625794c1ab5 /mesalib/configure.ac
parentd95b2ad7bc95e4ba2f1af9737935878f1ff7d79a (diff)
downloadvcxsrv-fb84fb26466262dcab4bd31bdf51c982f14f891a.tar.gz
vcxsrv-fb84fb26466262dcab4bd31bdf51c982f14f891a.tar.bz2
vcxsrv-fb84fb26466262dcab4bd31bdf51c982f14f891a.zip
fontconfig libfontenc mesa xserver git update 6 Mar 2013
xserver commit 103b77c59e3638a45179bf6d7908f5c738d2d872 libfontenc commit 624508365ec3279bc74ce523d024533e062629e1 fontconfig commit e96d7760886a3781a46b3271c76af99e15cb0146 mesa commit 88b20d58344ed336b146799c0bf1149a932dc2d7
Diffstat (limited to 'mesalib/configure.ac')
-rw-r--r--mesalib/configure.ac16
1 files changed, 1 insertions, 15 deletions
diff --git a/mesalib/configure.ac b/mesalib/configure.ac
index 5f95a78d2..ea56a044d 100644
--- a/mesalib/configure.ac
+++ b/mesalib/configure.ac
@@ -832,20 +832,6 @@ if test "x$enable_dri" = xyes; then
fi
fi
-dnl Find out if X is available.
-PKG_CHECK_MODULES([X11], [x11], [no_x=no], [no_x=yes])
-
-dnl Try to tell the user that the --x-* options are only used when
-dnl pkg-config is not available. This must be right after AC_PATH_XTRA.
-m4_divert_once([HELP_BEGIN],
-[These options are only used when the X libraries cannot be found by the
-pkg-config utility.])
-
-dnl We need X for xlib and dri, so bomb now if it's not found
-if test "x$enable_glx" = xyes -a "x$no_x" = xyes; then
- AC_MSG_ERROR([X11 development libraries needed for GLX])
-fi
-
dnl Direct rendering or just indirect rendering
case "$host_os" in
gnu*)
@@ -1095,7 +1081,7 @@ if test "x$enable_dri" = xyes; then
fi
# if we are building any dri driver other than swrast or using the dri state tracker ...
- if test -n "$DRI_DIRS" -a x"$DRI_DIRS" != xswrast || test "x$enable_dri" = xyes; then
+ if test -n "$DRI_DIRS" -a x"$DRI_DIRS" != xswrast -a "x$enable_dri" = xyes; then
# ... libdrm is required
if test "x$have_libdrm" != xyes; then
AC_MSG_ERROR([DRI drivers requires libdrm >= $LIBDRM_REQUIRED])