aboutsummaryrefslogtreecommitdiff
path: root/mesalib/src/mesa/drivers/dri/swrast/Makefile.am
diff options
context:
space:
mode:
authormarha <marha@users.sourceforge.net>2012-01-24 08:53:36 +0100
committermarha <marha@users.sourceforge.net>2012-01-24 08:53:36 +0100
commitb683b8f5675e280a6dd4ab82d6b9394182798b55 (patch)
tree0c4cec0e5b6284f65f9cd41e1becd29a8d0eaee8 /mesalib/src/mesa/drivers/dri/swrast/Makefile.am
parentaecb6b44ec50eb29377e903218f21b780d1eec51 (diff)
downloadvcxsrv-b683b8f5675e280a6dd4ab82d6b9394182798b55.tar.gz
vcxsrv-b683b8f5675e280a6dd4ab82d6b9394182798b55.tar.bz2
vcxsrv-b683b8f5675e280a6dd4ab82d6b9394182798b55.zip
libX11 mesa xserver git update 24 jan 2012
Diffstat (limited to 'mesalib/src/mesa/drivers/dri/swrast/Makefile.am')
-rw-r--r--mesalib/src/mesa/drivers/dri/swrast/Makefile.am58
1 files changed, 58 insertions, 0 deletions
diff --git a/mesalib/src/mesa/drivers/dri/swrast/Makefile.am b/mesalib/src/mesa/drivers/dri/swrast/Makefile.am
new file mode 100644
index 000000000..0a2800440
--- /dev/null
+++ b/mesalib/src/mesa/drivers/dri/swrast/Makefile.am
@@ -0,0 +1,58 @@
+
+
+# Copyright © 2012 Matt Turner <mattst88@gmail.com>
+#
+# Permission is hereby granted, free of charge, to any person obtaining a
+# copy of this software and associated documentation files (the "Software"),
+# to deal in the Software without restriction, including without limitation
+# the rights to use, copy, modify, merge, publish, distribute, sublicense,
+# and/or sell copies of the Software, and to permit persons to whom the
+# Software is furnished to do so, subject to the following conditions:
+#
+# The above copyright notice and this permission notice (including the next
+# paragraph) shall be included in all copies or substantial portions of the
+# Software.
+#
+# THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
+# IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
+# FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL
+# THE AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER
+# LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING
+# FROM, OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS
+# IN THE SOFTWARE.
+
+include Makefile.sources
+
+# Hack to make some of the non-automake variables work.
+TOP=$(top_builddir)
+
+AM_CFLAGS = \
+ -D__NOT_HAVE_DRM_H \
+ -I$(top_srcdir)/include \
+ -I$(top_srcdir)/src/ \
+ -I$(top_srcdir)/src/mapi \
+ -I$(top_srcdir)/src/mesa/ \
+ -I$(top_srcdir)/src/mesa/drivers/dri/common \
+ $(DEFINES) \
+ $(ASM_FLAGS) \
+ $(API_DEFINES)
+
+dridir = $(DRI_DRIVER_INSTALL_DIR)
+
+if HAVE_SWRAST_DRI
+dri_LTLIBRARIES = swrast_dri.la
+endif
+
+swrast_dri_la_SOURCES = \
+ $(SWRAST_C_FILES)
+
+swrast_dri_la_LDFLAGS = -module -avoid-version -shared
+swrast_dri_la_LIBADD = \
+ $(DRI_LIB_DEPS) \
+ $(DRICORE_LIB_DEPS)
+
+# Provide compatibility with scripts for the old Mesa build system for
+# a while by putting a link to the driver into /lib of the build tree.
+all-local: swrast_dri.la
+ $(MKDIR_P) $(top_builddir)/$(LIB_DIR);
+ ln -f .libs/swrast_dri.so $(top_builddir)/$(LIB_DIR)/swrast_dri.so;