aboutsummaryrefslogtreecommitdiff
path: root/mkfontscale/configure.ac
diff options
context:
space:
mode:
authormarha <marha@users.sourceforge.net>2011-03-25 15:37:13 +0000
committermarha <marha@users.sourceforge.net>2011-03-25 15:37:13 +0000
commit41a502478a2972358dec934d82ee401c61a5cd36 (patch)
tree3fda8100e6da9b4a2863789e393016a750502067 /mkfontscale/configure.ac
parent81aeaf653a832c4054d9a40b1cc796911521a739 (diff)
parent272e57235cd60a2e65ac8258d96a02eb3939b687 (diff)
downloadvcxsrv-41a502478a2972358dec934d82ee401c61a5cd36.tar.gz
vcxsrv-41a502478a2972358dec934d82ee401c61a5cd36.tar.bz2
vcxsrv-41a502478a2972358dec934d82ee401c61a5cd36.zip
svn merge ^/branches/released .
Diffstat (limited to 'mkfontscale/configure.ac')
-rw-r--r--mkfontscale/configure.ac128
1 files changed, 64 insertions, 64 deletions
diff --git a/mkfontscale/configure.ac b/mkfontscale/configure.ac
index 490e8cc45..697e29d91 100644
--- a/mkfontscale/configure.ac
+++ b/mkfontscale/configure.ac
@@ -1,64 +1,64 @@
-dnl Copyright 2005 Red Hat, Inc.
-dnl
-dnl Permission to use, copy, modify, distribute, and sell this software
-dnl and its documentation for any purpose is hereby granted without fee,
-dnl provided that the above copyright notice appear in all copies and
-dnl that both that copyright notice and this permission notice appear in
-dnl supporting documentation, and that the name of Red Hat not be used in
-dnl advertising or publicity pertaining to distribution of the software
-dnl without specific, written prior permission. Red Hat makes no
-dnl representations about the suitability of this software for any
-dnl purpose. It is provided "as is" without express or implied warranty.
-dnl
-dnl RED HAT DISCLAIMS ALL WARRANTIES WITH REGARD TO THIS SOFTWARE,
-dnl INCLUDING ALL IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS, IN
-dnl NO EVENT SHALL RED HAT BE LIABLE FOR ANY SPECIAL, INDIRECT OR
-dnl CONSEQUENTIAL DAMAGES OR ANY DAMAGES WHATSOEVER RESULTING FROM LOSS
-dnl OF USE, DATA OR PROFITS, WHETHER IN AN ACTION OF CONTRACT, NEGLIGENCE
-dnl OR OTHER TORTIOUS ACTION, ARISING OUT OF OR IN CONNECTION WITH THE
-dnl USE OR PERFORMANCE OF THIS SOFTWARE.
-dnl
-dnl Process this file with autoconf to create configure.
-
-AC_PREREQ([2.57])
-AC_INIT(mkfontscale, [1.0.7], [https://bugs.freedesktop.org/enter_bug.cgi?product=xorg], mkfontscale)
-AM_INIT_AUTOMAKE([dist-bzip2 foreign])
-AM_MAINTAINER_MODE
-
-AM_CONFIG_HEADER(config.h)
-
-# Require xorg-macros 1.3 or later: XORG_DEFAULT_OPTIONS
-m4_ifndef([XORG_MACROS_VERSION],
- [m4_fatal([must install xorg-macros 1.3 or later before running autoconf/autogen])])
-XORG_MACROS_VERSION(1.3)
-
-AC_PROG_CC
-AC_PROG_INSTALL
-
-XORG_DEFAULT_OPTIONS
-
-AC_CHECK_LIB(z, gzopen, [],
- [AC_MSG_ERROR([zlib is required, but was not found.])])
-
-AC_ARG_WITH(bzip2,
- AS_HELP_STRING([--with-bzip2],
- [Support bzip2 compressed bitmap fonts]),
- [], [with_bzip2=no])
-if test "x$with_bzip2" = xyes; then
- AC_CHECK_LIB(bz2, BZ2_bzopen, [],
- AC_MSG_ERROR([*** libbz2 is required for bzip2 support]))
- AC_DEFINE(X_BZIP2_FONT_COMPRESSION,1,[Support bzip2 for bitmap fonts])
-fi
-
-# Checks for pkg-config packages
-PKG_CHECK_MODULES(MKFONTSCALE, fontenc freetype2)
-AC_SUBST(MKFONTSCALE_CFLAGS)
-AC_SUBST(MKFONTSCALE_LIBS)
-
-PKG_CHECK_MODULES(X11, xproto)
-AC_SUBST(X11_CFLAGS)
-
-dnl Allow checking code with lint, sparse, etc.
-XORG_WITH_LINT
-
-AC_OUTPUT([Makefile])
+dnl Copyright 2005 Red Hat, Inc.
+dnl
+dnl Permission to use, copy, modify, distribute, and sell this software
+dnl and its documentation for any purpose is hereby granted without fee,
+dnl provided that the above copyright notice appear in all copies and
+dnl that both that copyright notice and this permission notice appear in
+dnl supporting documentation, and that the name of Red Hat not be used in
+dnl advertising or publicity pertaining to distribution of the software
+dnl without specific, written prior permission. Red Hat makes no
+dnl representations about the suitability of this software for any
+dnl purpose. It is provided "as is" without express or implied warranty.
+dnl
+dnl RED HAT DISCLAIMS ALL WARRANTIES WITH REGARD TO THIS SOFTWARE,
+dnl INCLUDING ALL IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS, IN
+dnl NO EVENT SHALL RED HAT BE LIABLE FOR ANY SPECIAL, INDIRECT OR
+dnl CONSEQUENTIAL DAMAGES OR ANY DAMAGES WHATSOEVER RESULTING FROM LOSS
+dnl OF USE, DATA OR PROFITS, WHETHER IN AN ACTION OF CONTRACT, NEGLIGENCE
+dnl OR OTHER TORTIOUS ACTION, ARISING OUT OF OR IN CONNECTION WITH THE
+dnl USE OR PERFORMANCE OF THIS SOFTWARE.
+dnl
+dnl Process this file with autoconf to create configure.
+
+# Initialize Autoconf
+AC_PREREQ([2.60])
+AC_INIT([mkfontscale], [1.0.8],
+ [https://bugs.freedesktop.org/enter_bug.cgi?product=xorg],
+ [mkfontscale])
+AC_CONFIG_SRCDIR([Makefile.am])
+AC_CONFIG_HEADERS([config.h])
+
+# Initialize Automake
+AM_INIT_AUTOMAKE([foreign dist-bzip2])
+AM_MAINTAINER_MODE
+
+# Require X.Org macros 1.8 or later for MAN_SUBSTS set by XORG_MANPAGE_SECTIONS
+m4_ifndef([XORG_MACROS_VERSION],
+ [m4_fatal([must install xorg-macros 1.8 or later before running autoconf/autogen])])
+XORG_MACROS_VERSION(1.8)
+XORG_DEFAULT_OPTIONS
+
+AC_CHECK_LIB(z, gzopen, [],
+ [AC_MSG_ERROR([zlib is required, but was not found.])])
+
+AC_ARG_WITH(bzip2,
+ AS_HELP_STRING([--with-bzip2],
+ [Support bzip2 compressed bitmap fonts]),
+ [], [with_bzip2=no])
+if test "x$with_bzip2" = xyes; then
+ AC_CHECK_LIB(bz2, BZ2_bzopen, [],
+ AC_MSG_ERROR([*** libbz2 is required for bzip2 support]))
+ AC_DEFINE(X_BZIP2_FONT_COMPRESSION,1,[Support bzip2 for bitmap fonts])
+fi
+
+# Checks for pkg-config packages
+PKG_CHECK_MODULES(MKFONTSCALE, fontenc freetype2)
+PKG_CHECK_MODULES(X11, xproto)
+
+dnl Allow checking code with lint, sparse, etc.
+XORG_WITH_LINT
+
+AC_CONFIG_FILES([
+ Makefile
+ man/Makefile])
+AC_OUTPUT