aboutsummaryrefslogtreecommitdiff
path: root/tools/mhmake/configure.in
diff options
context:
space:
mode:
authormarha <marha@users.sourceforge.net>2009-07-29 09:17:47 +0000
committermarha <marha@users.sourceforge.net>2009-07-29 09:17:47 +0000
commit437bca524595d1007f37988e862db8bfeff329b0 (patch)
treeda106b22babce6ccd53c7dd9c3040aed4a52f455 /tools/mhmake/configure.in
parent6f45caf0fe3e94a83835fa1f5d04233b9e936efc (diff)
downloadvcxsrv-437bca524595d1007f37988e862db8bfeff329b0.tar.gz
vcxsrv-437bca524595d1007f37988e862db8bfeff329b0.tar.bz2
vcxsrv-437bca524595d1007f37988e862db8bfeff329b0.zip
Added mhmake GNU make compatible (with extensions) make utility.
Diffstat (limited to 'tools/mhmake/configure.in')
-rw-r--r--tools/mhmake/configure.in20
1 files changed, 20 insertions, 0 deletions
diff --git a/tools/mhmake/configure.in b/tools/mhmake/configure.in
new file mode 100644
index 000000000..ca6a5389b
--- /dev/null
+++ b/tools/mhmake/configure.in
@@ -0,0 +1,20 @@
+AC_INIT(configure.in)
+
+AM_CONFIG_HEADER(config.h)
+AM_INIT_AUTOMAKE(mhmake, 0.1)
+
+AC_ARG_ENABLE(debug,
+[ --enable-debug Turn on debugging],
+[case "${enableval}" in
+ yes) debug=true ;;
+ full) debug=true ;;
+ no) debug=false ;;
+ *) AC_MSG_ERROR(bad value ${enableval} for --enable-debug) ;;
+esac],[debug=false])
+AM_CONDITIONAL(DEBUG, test x$debug = xtrue)
+
+AC_LANG_CPLUSPLUS
+AC_PROG_CXX
+AC_PROG_CC
+
+AC_OUTPUT(Makefile src/Makefile)