aboutsummaryrefslogtreecommitdiff
path: root/tools/mhmake/src/Makefile.am
diff options
context:
space:
mode:
authormarha <marha@users.sourceforge.net>2009-11-19 11:55:35 +0000
committermarha <marha@users.sourceforge.net>2009-11-19 11:55:35 +0000
commit659a361a09bcc4571966921f474e477860963723 (patch)
tree70c568428527e66f680cf7bdab80e39a6b17b5ef /tools/mhmake/src/Makefile.am
parent53cc6cb6ba430aad512bbdfc9828dd9b98682fbd (diff)
downloadvcxsrv-659a361a09bcc4571966921f474e477860963723.tar.gz
vcxsrv-659a361a09bcc4571966921f474e477860963723.tar.bz2
vcxsrv-659a361a09bcc4571966921f474e477860963723.zip
Solved compilation warnings in linux.
Diffstat (limited to 'tools/mhmake/src/Makefile.am')
-rw-r--r--tools/mhmake/src/Makefile.am8
1 files changed, 4 insertions, 4 deletions
diff --git a/tools/mhmake/src/Makefile.am b/tools/mhmake/src/Makefile.am
index 9e84d0f1f..be46f3bd6 100644
--- a/tools/mhmake/src/Makefile.am
+++ b/tools/mhmake/src/Makefile.am
@@ -24,26 +24,26 @@ mhmakeparser.cpp: mhmakeparser.y
mhmakeparser.h: mhmakeparser.y
.l.cpp:
- $(LEXCOMPILE) -S$(dir $<)flexskel.cc -H$(dir $<)flexskel.h -h$(@:%.cpp=%.h) -otemp1234.456 $<
+ $(LEXCOMPILE) -S$(srcdir)/flexskel.cc -H$(srcdir)/flexskel.h -h$(@:%.cpp=%.h) -otemp1234.456 $<
echo '#include "stdafx.h"' > $@
cat temp1234.456 >> $@
rm temp1234.456
.y.cpp:
- $(YACCCOMPILE) -S$(dir $<)bison.cc -H$(dir $<)bison.h -h$(@:%.cpp=%.h) -otemp1234.456 $<
+ $(YACCCOMPILE) -S$(srcdir)/bison.cc -H$(srcdir)/bison.h -h$(@:%.cpp=%.h) -otemp1234.456 $<
echo '#include "stdafx.h"' > $@
cat temp1234.456 >> $@
rm temp1234.456
.l.h:
- $(LEXCOMPILE) -S$(dir $<)flexskel.cc -H$(dir $<)flexskel.h -h$@ -otemp1234.456 $<
+ $(LEXCOMPILE) -S$(srcdir)/flexskel.cc -H$(srcdir)/flexskel.h -h$@ -otemp1234.456 $<
echo '#include "stdafx.h"' > $(@:%.h=%.cpp)
cat temp1234.456 >> $(@:%.h=%.cpp)
rm temp1234.456
.y.h:
- $(YACCCOMPILE) -S$(dir $<)bison.cc -H$(dir $<)bison.h -h$@ -otemp1234.456 $<
+ $(YACCCOMPILE) -S$(srcdir)/bison.cc -H$(srcdir)/bison.h -h$@ -otemp1234.456 $<
echo '#include "stdafx.h"' > $(@:%.h=%.cpp)
cat temp1234.456 >> $(@:%.h=%.cpp)
rm temp1234.456