aboutsummaryrefslogtreecommitdiff
path: root/xkbcomp/configure.ac
diff options
context:
space:
mode:
authormarha <marha@users.sourceforge.net>2010-11-02 07:32:01 +0000
committermarha <marha@users.sourceforge.net>2010-11-02 07:32:01 +0000
commit135e2e73bbe7155901a651c38b772e7b4547f39c (patch)
treec1c70fb185ca78b4608a113378a3e7430b91cf24 /xkbcomp/configure.ac
parent9af25cb02d1d2f86cd6e3cc1d18701f7304defdd (diff)
downloadvcxsrv-135e2e73bbe7155901a651c38b772e7b4547f39c.tar.gz
vcxsrv-135e2e73bbe7155901a651c38b772e7b4547f39c.tar.bz2
vcxsrv-135e2e73bbe7155901a651c38b772e7b4547f39c.zip
libX11 libXdmcp xkbcomp pixman git update 2/11/2010
Diffstat (limited to 'xkbcomp/configure.ac')
-rw-r--r--xkbcomp/configure.ac9
1 files changed, 6 insertions, 3 deletions
diff --git a/xkbcomp/configure.ac b/xkbcomp/configure.ac
index 15f268738..07822fe58 100644
--- a/xkbcomp/configure.ac
+++ b/xkbcomp/configure.ac
@@ -34,11 +34,14 @@ XORG_DEFAULT_OPTIONS
AM_CONFIG_HEADER(config.h)
+# If both the C file and YACC are missing, the package cannot be build.
AC_PROG_YACC
AC_PATH_PROG([YACC_INST], $YACC)
-AC_CHECK_FILE([$srcdir/xkbparse.c], [],
- [test -z "$YACC_INST" && AC_MSG_ERROR([yacc not found - unable to compile xkbparse.y])])
-
+if test ! -f "$srcdir/xkbparse.c"; then
+ if test -z "$YACC_INST"; then
+ AC_MSG_ERROR([yacc not found - unable to compile xkbparse.y])
+ fi
+fi
AC_CHECK_FUNCS([strdup strcasecmp])