aboutsummaryrefslogtreecommitdiff
path: root/xkbcomp/configure.ac
diff options
context:
space:
mode:
authormarha <marha@users.sourceforge.net>2010-08-05 19:33:41 +0000
committermarha <marha@users.sourceforge.net>2010-08-05 19:33:41 +0000
commitc115795736eb99a8f2288a06c231b9386f4d011f (patch)
treeb25a6096dfe3ace4dba840d4a67d26f723a7a709 /xkbcomp/configure.ac
parentd2758df0a0091496717fe7a65c3e7563e7c82785 (diff)
downloadvcxsrv-c115795736eb99a8f2288a06c231b9386f4d011f.tar.gz
vcxsrv-c115795736eb99a8f2288a06c231b9386f4d011f.tar.bz2
vcxsrv-c115795736eb99a8f2288a06c231b9386f4d011f.zip
xkbcomp git update 5/8/2010
Diffstat (limited to 'xkbcomp/configure.ac')
-rw-r--r--xkbcomp/configure.ac118
1 files changed, 59 insertions, 59 deletions
diff --git a/xkbcomp/configure.ac b/xkbcomp/configure.ac
index 007e7ca30..c4d2dc735 100644
--- a/xkbcomp/configure.ac
+++ b/xkbcomp/configure.ac
@@ -1,59 +1,59 @@
-dnl Copyright 2005 Red Hat, Inc.
-dnl
-dnl Permission to use, copy, modify, distribute, and sell this software and its
-dnl documentation for any purpose is hereby granted without fee, provided that
-dnl the above copyright notice appear in all copies and that both that
-dnl copyright notice and this permission notice appear in supporting
-dnl documentation, and that the name of Red Hat not be used in
-dnl advertising or publicity pertaining to distribution of the software without
-dnl specific, written prior permission. Red Hat makes no
-dnl representations about the suitability of this software for any purpose. It
-dnl is provided "as is" without express or implied warranty.
-dnl
-dnl RED HAT DISCLAIMS ALL WARRANTIES WITH REGARD TO THIS SOFTWARE,
-dnl INCLUDING ALL IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS, IN NO
-dnl EVENT SHALL RED HAT BE LIABLE FOR ANY SPECIAL, INDIRECT OR
-dnl CONSEQUENTIAL DAMAGES OR ANY DAMAGES WHATSOEVER RESULTING FROM LOSS OF USE,
-dnl DATA OR PROFITS, WHETHER IN AN ACTION OF CONTRACT, NEGLIGENCE OR OTHER
-dnl TORTIOUS ACTION, ARISING OUT OF OR IN CONNECTION WITH THE USE OR
-dnl PERFORMANCE OF THIS SOFTWARE.
-dnl
-dnl Process this file with autoconf to create configure.
-
-AC_PREREQ([2.57])
-AC_INIT(xkbcomp,[1.1.1], [https://bugs.freedesktop.org/enter_bug.cgi?product=xorg],xkbcomp)
-AM_INIT_AUTOMAKE([dist-bzip2])
-AM_MAINTAINER_MODE
-
-# Require xorg-macros: XORG_CWARNFLAGS, XORG_CHANGELOG
-m4_ifndef([XORG_MACROS_VERSION], [AC_FATAL([must install xorg-macros 1.2 or later before running autoconf/autogen])])
-XORG_MACROS_VERSION(1.2)
-
-AM_CONFIG_HEADER(config.h)
-
-AC_PROG_CC
-AC_PROG_YACC
-AC_PROG_INSTALL
-
-XORG_CWARNFLAGS
-
-AC_CHECK_FUNCS([strdup strcasecmp])
-
-# Checks for pkg-config packages
-PKG_CHECK_MODULES(XKBCOMP, x11 xkbfile)
-XKBCOMP_CFLAGS="$CWARNFLAGS $XKBCOMP_CFLAGS"
-AC_SUBST(XKBCOMP_CFLAGS)
-AC_SUBST(XKBCOMP_LIBS)
-
-AC_ARG_WITH([xkb_config_root],
- [AC_HELP_STRING([--with-xkb-config-root=<paths>],
- [Set default XKB config root (default: ${datadir}/X11/xkb)])],
- [XKBCONFIGROOT="$withval"],
- [XKBCONFIGROOT='${datadir}/X11/xkb'])
-AC_SUBST([XKBCONFIGROOT])
-
-XORG_MANPAGE_SECTIONS
-XORG_RELEASE_VERSION
-XORG_CHANGELOG
-
-AC_OUTPUT([Makefile])
+dnl Copyright 2005 Red Hat, Inc.
+dnl
+dnl Permission to use, copy, modify, distribute, and sell this software and its
+dnl documentation for any purpose is hereby granted without fee, provided that
+dnl the above copyright notice appear in all copies and that both that
+dnl copyright notice and this permission notice appear in supporting
+dnl documentation, and that the name of Red Hat not be used in
+dnl advertising or publicity pertaining to distribution of the software without
+dnl specific, written prior permission. Red Hat makes no
+dnl representations about the suitability of this software for any purpose. It
+dnl is provided "as is" without express or implied warranty.
+dnl
+dnl RED HAT DISCLAIMS ALL WARRANTIES WITH REGARD TO THIS SOFTWARE,
+dnl INCLUDING ALL IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS, IN NO
+dnl EVENT SHALL RED HAT BE LIABLE FOR ANY SPECIAL, INDIRECT OR
+dnl CONSEQUENTIAL DAMAGES OR ANY DAMAGES WHATSOEVER RESULTING FROM LOSS OF USE,
+dnl DATA OR PROFITS, WHETHER IN AN ACTION OF CONTRACT, NEGLIGENCE OR OTHER
+dnl TORTIOUS ACTION, ARISING OUT OF OR IN CONNECTION WITH THE USE OR
+dnl PERFORMANCE OF THIS SOFTWARE.
+dnl
+dnl Process this file with autoconf to create configure.
+
+AC_PREREQ([2.57])
+AC_INIT(xkbcomp,[1.1.1], [https://bugs.freedesktop.org/enter_bug.cgi?product=xorg],xkbcomp)
+AM_INIT_AUTOMAKE([foreign dist-bzip2])
+AM_MAINTAINER_MODE
+
+# Require xorg-macros: XORG_DEFAULT_OPTIONS
+m4_ifndef([XORG_MACROS_VERSION],
+ [m4_fatal([must install xorg-macros 1.3 or later before running autoconf/autogen])])
+XORG_MACROS_VERSION(1.3)
+XORG_DEFAULT_OPTIONS
+
+AM_CONFIG_HEADER(config.h)
+
+AC_PROG_CC
+AC_PROG_YACC
+AC_PATH_PROG([YACC_INST], $YACC)
+AC_CHECK_FILE([$srcdir/xkbparse.c], [],
+ [test -z "$YACC_INST" && AC_MSG_ERROR([yacc not found - unable to compile xkbparse.y])])
+AC_PROG_INSTALL
+
+
+AC_CHECK_FUNCS([strdup strcasecmp])
+
+# Checks for pkg-config packages
+PKG_CHECK_MODULES(XKBCOMP, x11 xkbfile)
+AC_SUBST(XKBCOMP_CFLAGS)
+AC_SUBST(XKBCOMP_LIBS)
+
+AC_ARG_WITH([xkb_config_root],
+ [AC_HELP_STRING([--with-xkb-config-root=<paths>],
+ [Set default XKB config root (default: ${datadir}/X11/xkb)])],
+ [XKBCONFIGROOT="$withval"],
+ [XKBCONFIGROOT='${datadir}/X11/xkb'])
+AC_SUBST([XKBCONFIGROOT])
+
+
+AC_OUTPUT([Makefile])