aboutsummaryrefslogtreecommitdiff
path: root/xorg-server/fonts.src/encodings/configure.ac
diff options
context:
space:
mode:
authormarha <marha@users.sourceforge.net>2011-03-25 15:37:13 +0000
committermarha <marha@users.sourceforge.net>2011-03-25 15:37:13 +0000
commit41a502478a2972358dec934d82ee401c61a5cd36 (patch)
tree3fda8100e6da9b4a2863789e393016a750502067 /xorg-server/fonts.src/encodings/configure.ac
parent81aeaf653a832c4054d9a40b1cc796911521a739 (diff)
parent272e57235cd60a2e65ac8258d96a02eb3939b687 (diff)
downloadvcxsrv-41a502478a2972358dec934d82ee401c61a5cd36.tar.gz
vcxsrv-41a502478a2972358dec934d82ee401c61a5cd36.tar.bz2
vcxsrv-41a502478a2972358dec934d82ee401c61a5cd36.zip
svn merge ^/branches/released .
Diffstat (limited to 'xorg-server/fonts.src/encodings/configure.ac')
-rw-r--r--xorg-server/fonts.src/encodings/configure.ac102
1 files changed, 52 insertions, 50 deletions
diff --git a/xorg-server/fonts.src/encodings/configure.ac b/xorg-server/fonts.src/encodings/configure.ac
index 43bfa1556..b598b1594 100644
--- a/xorg-server/fonts.src/encodings/configure.ac
+++ b/xorg-server/fonts.src/encodings/configure.ac
@@ -1,50 +1,52 @@
-AC_PREREQ([2.57])
-AC_INIT([encodings], [1.0.3], [https://bugs.freedesktop.org/enter_bug.cgi?product=xorg])
-AM_INIT_AUTOMAKE([foreign dist-bzip2])
-
-# Require xorg-macros: XORG_DEFAULT_OPTIONS
-m4_ifndef([XORG_MACROS_VERSION],
- [m4_fatal([must install xorg-macros 1.3 or later before running autoconf/autogen])])
-XORG_MACROS_VERSION(1.3)
-XORG_DEFAULT_OPTIONS
-
-AC_PROG_INSTALL
-
-# Require X.Org's font util macros 1.1 or later
-m4_ifndef([XORG_FONT_MACROS_VERSION],
- [m4_fatal([must install X.Org font-util 1.1 or later before running autoconf/autogen])])
-XORG_FONT_MACROS_VERSION(1.1)
-
-# mkfontscale
-XORG_FONT_REQUIRED_PROG(MKFONTSCALE, mkfontscale)
-
-# Choose whether or not to compress encodings - default is to compress all
-
-AC_MSG_CHECKING([if small encodings should be compressed])
-AC_ARG_ENABLE(gzip-small-encodings,
- AC_HELP_STRING([--disable-gzip-small-encodings],
- [Disable compression of small encoding files]),
- [GZIP_SMALL="$enableval"], [GZIP_SMALL="yes"])
-AM_CONDITIONAL(GZIP_SMALL, [test x$GZIP_SMALL = xyes])
-AC_MSG_RESULT([${GZIP_SMALL}])
-
-AC_MSG_CHECKING([if large encodings should be compressed])
-AC_ARG_ENABLE(gzip-large-encodings,
- AC_HELP_STRING([--disable-gzip-large-encodings],
- [Disable compression of large encoding files]),
- [GZIP_LARGE="$enableval"], [GZIP_LARGE="yes"])
-AM_CONDITIONAL(GZIP_LARGE, [test x$GZIP_LARGE = xyes])
-AC_MSG_RESULT([${GZIP_LARGE}])
-
-# gzip
-
-if test x$GZIP_SMALL = xyes -o x$GZIP_LARGE = xyes ; then
- AC_PATH_PROG(GZIP, gzip)
- if [[ -z $GZIP ]]; then
- AC_MSG_ERROR([gzip is needed to compress font encodings])
- fi
-fi
-
-XORG_FONTSUBDIR([ENCODINGSDIR], [encodingsdir], [encodings])
-
-AC_OUTPUT([Makefile large/Makefile])
+AC_PREREQ([2.60])
+AC_INIT([encodings], [1.0.4],
+ [https://bugs.freedesktop.org/enter_bug.cgi?product=xorg])
+AM_INIT_AUTOMAKE([foreign dist-bzip2])
+AM_MAINTAINER_MODE
+
+# Require xorg-macros: XORG_DEFAULT_OPTIONS
+m4_ifndef([XORG_MACROS_VERSION],
+ [m4_fatal([must install xorg-macros 1.3 or later before running autoconf/autogen])])
+XORG_MACROS_VERSION(1.3)
+XORG_DEFAULT_OPTIONS
+
+AC_PROG_INSTALL
+
+# Require X.Org's font util macros 1.2 or later
+m4_ifndef([XORG_FONT_MACROS_VERSION],
+ [m4_fatal([must install X.Org font-util 1.2 or later before running autoconf/autogen])])
+XORG_FONT_MACROS_VERSION(1.2)
+
+# mkfontscale
+XORG_FONT_REQUIRED_PROG(MKFONTSCALE, mkfontscale)
+
+# Choose whether or not to compress encodings - default is to compress all
+
+AC_MSG_CHECKING([if small encodings should be compressed])
+AC_ARG_ENABLE(gzip-small-encodings,
+ AC_HELP_STRING([--disable-gzip-small-encodings],
+ [Disable compression of small encoding files]),
+ [GZIP_SMALL="$enableval"], [GZIP_SMALL="yes"])
+AM_CONDITIONAL(GZIP_SMALL, [test x$GZIP_SMALL = xyes])
+AC_MSG_RESULT([${GZIP_SMALL}])
+
+AC_MSG_CHECKING([if large encodings should be compressed])
+AC_ARG_ENABLE(gzip-large-encodings,
+ AC_HELP_STRING([--disable-gzip-large-encodings],
+ [Disable compression of large encoding files]),
+ [GZIP_LARGE="$enableval"], [GZIP_LARGE="yes"])
+AM_CONDITIONAL(GZIP_LARGE, [test x$GZIP_LARGE = xyes])
+AC_MSG_RESULT([${GZIP_LARGE}])
+
+# gzip
+
+if test x$GZIP_SMALL = xyes -o x$GZIP_LARGE = xyes ; then
+ AC_PATH_PROG(GZIP, gzip)
+ if [[ -z $GZIP ]]; then
+ AC_MSG_ERROR([gzip is needed to compress font encodings])
+ fi
+fi
+
+XORG_FONTSUBDIR([ENCODINGSDIR], [encodingsdir], [encodings])
+
+AC_OUTPUT([Makefile large/Makefile])