aboutsummaryrefslogtreecommitdiff
path: root/xorg-server/hw/xfree86/Makefile.am
diff options
context:
space:
mode:
authormarha <marha@users.sourceforge.net>2014-03-25 17:56:10 +0100
committermarha <marha@users.sourceforge.net>2014-03-25 17:56:10 +0100
commitba6115f56f066621a20fa545ddd67721afd35523 (patch)
tree418b724d4f318d24dc8e5183e6b252922f85f149 /xorg-server/hw/xfree86/Makefile.am
parenteb71c0f23999d1cc156e1821d73634ec79621fc2 (diff)
parente0927d908a12c9c140458c355b29b884a7705f2d (diff)
downloadvcxsrv-ba6115f56f066621a20fa545ddd67721afd35523.tar.gz
vcxsrv-ba6115f56f066621a20fa545ddd67721afd35523.tar.bz2
vcxsrv-ba6115f56f066621a20fa545ddd67721afd35523.zip
Merge remote-tracking branch 'origin/released'
Conflicts: xorg-server/hw/xwin/InitInput.c xorg-server/hw/xwin/InitOutput.c xorg-server/hw/xwin/winglobals.c xorg-server/hw/xwin/winglobals.h xorg-server/hw/xwin/winmsgwindow.c xorg-server/hw/xwin/winmultiwindowwm.c xorg-server/hw/xwin/winmultiwindowwndproc.c
Diffstat (limited to 'xorg-server/hw/xfree86/Makefile.am')
-rw-r--r--xorg-server/hw/xfree86/Makefile.am15
1 files changed, 13 insertions, 2 deletions
diff --git a/xorg-server/hw/xfree86/Makefile.am b/xorg-server/hw/xfree86/Makefile.am
index 73e1b4c1f..a315bbc17 100644
--- a/xorg-server/hw/xfree86/Makefile.am
+++ b/xorg-server/hw/xfree86/Makefile.am
@@ -81,9 +81,15 @@ Xorg_DEPENDENCIES = $(LOCAL_LIBS)
Xorg_LDFLAGS = $(LD_EXPORT_SYMBOLS_FLAG)
+if SUID_WRAPPER
+wrapdir = $(SUID_WRAPPER_DIR)
+wrap_PROGRAMS = Xorg.wrap
+Xorg_wrap_SOURCES = xorg-wrapper.c
+endif
+
BUILT_SOURCES = xorg.conf.example
DISTCLEANFILES = xorg.conf.example
-EXTRA_DIST = xorgconf.cpp
+EXTRA_DIST = xorgconf.cpp Xorg.sh.in
# Without logdir, X will post an error on the terminal and will not start
install-data-local:
@@ -98,6 +104,11 @@ if INSTALL_SETUID
chown root $(DESTDIR)$(bindir)/Xorg
chmod u+s $(DESTDIR)$(bindir)/Xorg
endif
+if SUID_WRAPPER
+ mv $(DESTDIR)$(bindir)/Xorg $(DESTDIR)$(SUID_WRAPPER_DIR)/Xorg.bin
+ ${INSTALL} -m 755 Xorg.sh $(DESTDIR)$(bindir)/Xorg
+ -chown root $(DESTDIR)$(SUID_WRAPPER_DIR)/Xorg.wrap && chmod u+s $(DESTDIR)$(SUID_WRAPPER_DIR)/Xorg.wrap
+endif
uninstall-local:
if CYGWIN
@@ -119,7 +130,7 @@ xorg.conf.example: xorgconf.cpp
relink:
$(AM_V_at)rm -f Xorg$(EXEEXT) && $(MAKE) Xorg$(EXEEXT)
-CLEANFILES = sdksyms.c sdksyms.dep
+CLEANFILES = sdksyms.c sdksyms.dep Xorg.sh
EXTRA_DIST += sdksyms.sh
sdksyms.dep sdksyms.c: sdksyms.sh