aboutsummaryrefslogtreecommitdiff
path: root/xorg-server/test/Makefile.am
diff options
context:
space:
mode:
authormarha <marha@users.sourceforge.net>2011-07-01 16:49:54 +0200
committermarha <marha@users.sourceforge.net>2011-07-01 16:49:54 +0200
commit3bbcbc59b6d98f09b26f39d6208faec76cc6aa3e (patch)
tree3e798726828ac0fa7153e841f77f8d4cf52855db /xorg-server/test/Makefile.am
parent83cb62fe8002927ba95861a4fd21cc44c48bfcf7 (diff)
parentd9f970a847e1af706f07560ef163b229bb592307 (diff)
downloadvcxsrv-3bbcbc59b6d98f09b26f39d6208faec76cc6aa3e.tar.gz
vcxsrv-3bbcbc59b6d98f09b26f39d6208faec76cc6aa3e.tar.bz2
vcxsrv-3bbcbc59b6d98f09b26f39d6208faec76cc6aa3e.zip
Merge remote-tracking branch 'origin/released'
Conflicts: apps/xwininfo/configure.ac libX11/configure.ac mesalib/src/glsl/ast_function.cpp mesalib/src/glsl/ast_to_hir.cpp mesalib/src/glsl/glsl_parser_extras.cpp mesalib/src/glsl/glsl_parser_extras.h mesalib/src/glsl/ir.cpp mesalib/src/glsl/ir.h mesalib/src/glsl/ir_constant_expression.cpp mesalib/src/glsl/ir_validate.cpp mesalib/src/glsl/lower_mat_op_to_vec.cpp mesalib/src/mesa/program/ir_to_mesa.cpp mesalib/src/mesa/state_tracker/st_cb_drawpixels.c mesalib/src/mesa/state_tracker/st_cb_texture.c mesalib/src/mesa/state_tracker/st_context.h mesalib/src/mesa/state_tracker/st_format.h mkfontscale/configure.ac xorg-server/Xext/xvmc.c xorg-server/configure.ac xorg-server/dix/Makefile.am xorg-server/fb/fbarc.c xorg-server/fb/fbgc.c xorg-server/glx/glapi_gentable.c xorg-server/glx/glxdri2.c xorg-server/glx/glxscreens.c xorg-server/hw/xfree86/Makefile.am xorg-server/hw/xfree86/loader/Makefile.am xorg-server/hw/xquartz/X11Application.m xorg-server/hw/xquartz/mach-startup/Makefile.am xorg-server/hw/xwin/XWin.rc xorg-server/hw/xwin/winmultiwindowwindow.c xorg-server/hw/xwin/winmultiwindowwndproc.c xorg-server/os/Makefile.am xorg-server/test/Makefile.am xorg-server/xfixes/region.c xorg-server/xkeyboard-config/symbols/ma
Diffstat (limited to 'xorg-server/test/Makefile.am')
-rw-r--r--xorg-server/test/Makefile.am12
1 files changed, 5 insertions, 7 deletions
diff --git a/xorg-server/test/Makefile.am b/xorg-server/test/Makefile.am
index eb91d70d3..19133bc28 100644
--- a/xorg-server/test/Makefile.am
+++ b/xorg-server/test/Makefile.am
@@ -7,7 +7,10 @@ check_LTLIBRARIES = libxservertest.la
TESTS=$(noinst_PROGRAMS)
AM_CFLAGS = $(DIX_CFLAGS) @XORG_CFLAGS@
-INCLUDES = @XORG_INCS@
+INCLUDES = $(XORG_INCS) -I$(top_srcdir)/hw/xfree86/parser \
+ -I$(top_srcdir)/miext/cw -I$(top_srcdir)/hw/xfree86/ddc \
+ -I$(top_srcdir)/hw/xfree86/i2c -I$(top_srcdir)/hw/xfree86/modes \
+ -I$(top_srcdir)/hw/xfree86/ramdac
TEST_LDADD=libxservertest.la $(XORG_SYS_LIBS) $(XSERVER_SYS_LIBS)
if SPECIAL_DTRACE_OBJECTS
@@ -21,6 +24,7 @@ list_LDADD=$(TEST_LDADD)
misc_LDADD=$(TEST_LDADD)
fixes_LDADD=$(TEST_LDADD)
+nodist_libxservertest_la_SOURCES = $(top_builddir)/hw/xfree86/sdksyms.c
libxservertest_la_LIBADD = \
$(XSERVER_LIBS) \
$(top_builddir)/hw/xfree86/loader/libloader.la \
@@ -33,14 +37,8 @@ libxservertest_la_LIBADD = \
$(top_builddir)/hw/xfree86/ddc/libddc.la \
$(top_builddir)/hw/xfree86/i2c/libi2c.la \
$(top_builddir)/hw/xfree86/dixmods/libxorgxkb.la \
- $(top_builddir)/hw/xfree86/libxorg.la \
$(top_builddir)/mi/libmi.la \
$(top_builddir)/os/libos.la \
@XORG_LIBS@
endif
endif
-
-CLEANFILES=libxservertest.c
-
-libxservertest.c:
- touch $@