aboutsummaryrefslogtreecommitdiff
path: root/X11/xtrans/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'X11/xtrans/Makefile.am')
-rw-r--r--X11/xtrans/Makefile.am27
1 files changed, 27 insertions, 0 deletions
diff --git a/X11/xtrans/Makefile.am b/X11/xtrans/Makefile.am
new file mode 100644
index 000000000..39b67d36d
--- /dev/null
+++ b/X11/xtrans/Makefile.am
@@ -0,0 +1,27 @@
+Xtransincludedir = $(includedir)/X11/Xtrans
+Xtransinclude_HEADERS = \
+ Xtrans.h \
+ Xtrans.c \
+ Xtransint.h \
+ Xtranslcl.c \
+ Xtranssock.c \
+ Xtranstli.c \
+ Xtransutil.c \
+ transport.c
+
+aclocaldir = $(datadir)/aclocal
+aclocal_DATA = xtrans.m4
+
+pkgconfigdir = $(libdir)/pkgconfig
+pkgconfig_DATA = xtrans.pc
+
+EXTRA_DIST = xtrans.pc.in ${aclocal_DATA}
+
+CLEANFILES = ChangeLog
+
+.PHONY: ChangeLog
+
+ChangeLog:
+ (GIT_DIR=$(top_srcdir)/.git git-log > .changelog.tmp && mv .changelog.tmp ChangeLog; rm -f .changelog.tmp) || (touch ChangeLog; echo 'git directory not found: installing possibly empty changelog.' >&2)
+
+dist-hook: ChangeLog