aboutsummaryrefslogtreecommitdiff
path: root/apps/xauth/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'apps/xauth/Makefile.am')
-rw-r--r--apps/xauth/Makefile.am53
1 files changed, 53 insertions, 0 deletions
diff --git a/apps/xauth/Makefile.am b/apps/xauth/Makefile.am
new file mode 100644
index 000000000..972c84154
--- /dev/null
+++ b/apps/xauth/Makefile.am
@@ -0,0 +1,53 @@
+#
+# Copyright 2005 Red Hat, Inc.
+#
+# Permission to use, copy, modify, distribute, and sell this software and its
+# documentation for any purpose is hereby granted without fee, provided that
+# the above copyright notice appear in all copies and that both that
+# copyright notice and this permission notice appear in supporting
+# documentation, and that the name of Red Hat not be used in
+# advertising or publicity pertaining to distribution of the software without
+# specific, written prior permission. Red Hat makes no
+# representations about the suitability of this software for any purpose. It
+# is provided "as is" without express or implied warranty.
+#
+# RED HAT DISCLAIMS ALL WARRANTIES WITH REGARD TO THIS SOFTWARE,
+# INCLUDING ALL IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS, IN NO
+# EVENT SHALL RED HAT BE LIABLE FOR ANY SPECIAL, INDIRECT OR
+# CONSEQUENTIAL DAMAGES OR ANY DAMAGES WHATSOEVER RESULTING FROM LOSS OF USE,
+# DATA OR PROFITS, WHETHER IN AN ACTION OF CONTRACT, NEGLIGENCE OR OTHER
+# TORTIOUS ACTION, ARISING OUT OF OR IN CONNECTION WITH THE USE OR
+# PERFORMANCE OF THIS SOFTWARE.
+
+SUBDIRS = man
+bin_PROGRAMS = xauth
+
+AM_CFLAGS = $(CWARNFLAGS) $(XAUTH_CFLAGS)
+xauth_LDADD = $(XAUTH_LIBS)
+
+xauth_SOURCES = \
+ gethost.c \
+ parsedpy.c \
+ process.c \
+ xauth.c \
+ xauth.h
+
+if LINT
+ALL_LINT_FLAGS=$(LINT_FLAGS) $(DEFS) $(DEFAULT_INCLUDES) $(INCLUDES) \
+ $(AM_CPPFLAGS) $(CPPFLAGS) $(XAUTH_CFLAGS)
+
+lint:
+ $(LINT) $(ALL_LINT_FLAGS) $(xauth_SOURCES) $(xauth_LDADD)
+endif LINT
+
+MAINTAINERCLEANFILES = ChangeLog INSTALL
+
+.PHONY: ChangeLog INSTALL
+
+INSTALL:
+ $(INSTALL_CMD)
+
+ChangeLog:
+ $(CHANGELOG_CMD)
+
+dist-hook: ChangeLog INSTALL