aboutsummaryrefslogtreecommitdiff
path: root/apps/xauth/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'apps/xauth/configure.ac')
-rw-r--r--apps/xauth/configure.ac57
1 files changed, 57 insertions, 0 deletions
diff --git a/apps/xauth/configure.ac b/apps/xauth/configure.ac
new file mode 100644
index 000000000..1262e00c7
--- /dev/null
+++ b/apps/xauth/configure.ac
@@ -0,0 +1,57 @@
+dnl Copyright 2005 Red Hat, Inc.
+dnl
+dnl Permission to use, copy, modify, distribute, and sell this software and its
+dnl documentation for any purpose is hereby granted without fee, provided that
+dnl the above copyright notice appear in all copies and that both that
+dnl copyright notice and this permission notice appear in supporting
+dnl documentation, and that the name of Red Hat not be used in
+dnl advertising or publicity pertaining to distribution of the software without
+dnl specific, written prior permission. Red Hat makes no
+dnl representations about the suitability of this software for any purpose. It
+dnl is provided "as is" without express or implied warranty.
+dnl
+dnl RED HAT DISCLAIMS ALL WARRANTIES WITH REGARD TO THIS SOFTWARE,
+dnl INCLUDING ALL IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS, IN NO
+dnl EVENT SHALL RED HAT BE LIABLE FOR ANY SPECIAL, INDIRECT OR
+dnl CONSEQUENTIAL DAMAGES OR ANY DAMAGES WHATSOEVER RESULTING FROM LOSS OF USE,
+dnl DATA OR PROFITS, WHETHER IN AN ACTION OF CONTRACT, NEGLIGENCE OR OTHER
+dnl TORTIOUS ACTION, ARISING OUT OF OR IN CONNECTION WITH THE USE OR
+dnl PERFORMANCE OF THIS SOFTWARE.
+dnl
+dnl Process this file with autoconf to create configure.
+
+AC_PREREQ([2.60])
+AC_INIT([xauth],
+ [1.0.6],
+ [https://bugs.freedesktop.org/enter_bug.cgi?product=xorg],
+ [xauth])
+AM_INIT_AUTOMAKE([foreign dist-bzip2])
+AM_MAINTAINER_MODE
+
+AC_CONFIG_HEADERS([config.h])
+
+# Require X.Org macros 1.8 or later for MAN_SUBSTS set by XORG_MANPAGE_SECTIONS
+m4_ifndef([XORG_MACROS_VERSION],
+ [m4_fatal([must install xorg-macros 1.8 or later before running autoconf/autogen])])
+XORG_MACROS_VERSION(1.8)
+XORG_DEFAULT_OPTIONS
+
+AC_TYPE_SIGNAL
+
+AC_CHECK_HEADERS([net/errno.h])
+
+AC_CHECK_FUNCS([strlcpy])
+
+# Checks for pkg-config packages
+PKG_CHECK_MODULES(XAUTH, x11 xau xext xmuu)
+
+# Transport selection macro from xtrans.m4
+# Needed to set *CONN defines for gethost.c & parsedpy.c
+XTRANS_CONNECTION_FLAGS
+
+XORG_WITH_LINT
+
+AC_CONFIG_FILES([
+ Makefile
+ man/Makefile])
+AC_OUTPUT