aboutsummaryrefslogtreecommitdiff
path: root/apps/xcalc/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'apps/xcalc/Makefile.am')
-rw-r--r--apps/xcalc/Makefile.am25
1 files changed, 5 insertions, 20 deletions
diff --git a/apps/xcalc/Makefile.am b/apps/xcalc/Makefile.am
index dacb04187..52d27211b 100644
--- a/apps/xcalc/Makefile.am
+++ b/apps/xcalc/Makefile.am
@@ -1,6 +1,6 @@
-#
+#
# Copyright 2005 Red Hat, Inc.
-#
+#
# Permission to use, copy, modify, distribute, and sell this software and its
# documentation for any purpose is hereby granted without fee, provided that
# the above copyright notice appear in all copies and that both that
@@ -10,7 +10,7 @@
# specific, written prior permission. Red Hat makes no
# representations about the suitability of this software for any purpose. It
# is provided "as is" without express or implied warranty.
-#
+#
# RED HAT DISCLAIMS ALL WARRANTIES WITH REGARD TO THIS SOFTWARE,
# INCLUDING ALL IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS, IN NO
# EVENT SHALL RED HAT BE LIABLE FOR ANY SPECIAL, INDIRECT OR
@@ -19,6 +19,7 @@
# TORTIOUS ACTION, ARISING OUT OF OR IN CONNECTION WITH THE USE OR
# PERFORMANCE OF THIS SOFTWARE.
+SUBDIRS = man
bin_PROGRAMS = xcalc
AM_CFLAGS = $(XCALC_CFLAGS) $(CWARNFLAGS)
@@ -30,9 +31,6 @@ xcalc_SOURCES = \
xcalc.c \
xcalc.h
-appman_PRE = \
- xcalc.man
-
# App default files (*.ad)
DISTCHECK_CONFIGURE_FLAGS = --with-appdefaultdir=\$${datadir}/X11/app-defaults
@@ -43,7 +41,7 @@ dist_appdefault_DATA = \
app-defaults/XCalc \
app-defaults/XCalc-color
-
+MAINTAINERCLEANFILES = ChangeLog INSTALL
.PHONY: ChangeLog INSTALL
@@ -55,16 +53,3 @@ ChangeLog:
dist-hook: ChangeLog INSTALL
-appmandir = $(APP_MAN_DIR)
-
-appman_DATA = $(appman_PRE:man=@APP_MAN_SUFFIX@)
-
-EXTRA_DIST = $(appman_PRE) autogen.sh
-MAINTAINERCLEANFILES = ChangeLog INSTALL
-CLEANFILES = $(appman_DATA)
-
-SUFFIXES = .$(APP_MAN_SUFFIX) .man
-
-# String replacements in MAN_SUBSTS now come from xorg-macros.m4 via configure
-.man.$(APP_MAN_SUFFIX):
- $(AM_V_GEN)$(SED) $(MAN_SUBSTS) < $< > $@