aboutsummaryrefslogtreecommitdiff
path: root/apps/xcalc/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'apps/xcalc/configure.ac')
-rw-r--r--apps/xcalc/configure.ac35
1 files changed, 21 insertions, 14 deletions
diff --git a/apps/xcalc/configure.ac b/apps/xcalc/configure.ac
index ee2077566..c511b46ef 100644
--- a/apps/xcalc/configure.ac
+++ b/apps/xcalc/configure.ac
@@ -21,26 +21,33 @@ dnl PERFORMANCE OF THIS SOFTWARE.
dnl
dnl Process this file with autoconf to create configure.
-AC_PREREQ([2.57])
-AC_INIT(xcalc,[1.0.2], [https://bugs.freedesktop.org/enter_bug.cgi?product=xorg],xcalc)
-AM_INIT_AUTOMAKE([dist-bzip2])
+# Initialize Autoconf
+AC_PREREQ([2.60])
+AC_INIT([xcalc], [1.0.4.1],
+ [https://bugs.freedesktop.org/enter_bug.cgi?product=xorg], [xcalc])
+AC_CONFIG_SRCDIR([Makefile.am])
+AC_CONFIG_HEADERS([config.h])
+
+# Initialize Automake
+AM_INIT_AUTOMAKE([foreign dist-bzip2])
AM_MAINTAINER_MODE
-AM_CONFIG_HEADER(config.h)
+# Require X.Org macros 1.8 or later for MAN_SUBSTS set by XORG_MANPAGE_SECTIONS
+m4_ifndef([XORG_MACROS_VERSION],
+ [m4_fatal([must install xorg-macros 1.8 or later before running autoconf/autogen])])
+XORG_MACROS_VERSION(1.8)
+XORG_DEFAULT_OPTIONS
-AC_PROG_CC
-AC_PROG_INSTALL
-
-XAW_CHECK_XPRINT_SUPPORT(XCALC)
-
-AC_SUBST(XCALC_CFLAGS)
-AC_SUBST(XCALC_LIBS)
+# Checks for pkg-config packages
+PKG_CHECK_MODULES(XCALC, xaw7 xt x11)
PKG_CHECK_MODULES(APPDEFS, xt)
-appdefaultdir=$(pkg-config --variable=appdefaultdir xt)
+xt_appdefaultdir=`$PKG_CONFIG --variable=appdefaultdir xt`
+AC_ARG_WITH(appdefaultdir,
+ AC_HELP_STRING([--with-appdefaultdir=<pathname>],
+ [specify directory for app-defaults files (default is autodetected)]),
+ [appdefaultdir="$withval"], [appdefaultdir="${xt_appdefaultdir}"])
AC_SUBST(appdefaultdir)
-XORG_MANPAGE_SECTIONS
-XORG_RELEASE_VERSION
AC_OUTPUT([Makefile])