aboutsummaryrefslogtreecommitdiff
path: root/apps/xhost/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'apps/xhost/configure.ac')
-rw-r--r--apps/xhost/configure.ac24
1 files changed, 16 insertions, 8 deletions
diff --git a/apps/xhost/configure.ac b/apps/xhost/configure.ac
index 9d70b8c60..1b069e8c3 100644
--- a/apps/xhost/configure.ac
+++ b/apps/xhost/configure.ac
@@ -1,8 +1,13 @@
-# $XdotOrg: app/xhost/configure.ac,v 1.10 2005/12/15 00:24:07 kem Exp $
+dnl Process this file with autoconf to create configure.
+# Initialize Autoconf
AC_PREREQ([2.60])
-AC_INIT([xhost], [1.0.4],
+AC_INIT([xhost], [1.0.5],
[https://bugs.freedesktop.org/enter_bug.cgi?product=xorg], [xhost])
+AC_CONFIG_SRCDIR([Makefile.am])
+AC_CONFIG_HEADERS([config.h])
+
+# Initialize Automake
AM_INIT_AUTOMAKE([foreign dist-bzip2])
AM_MAINTAINER_MODE
@@ -10,15 +15,15 @@ AM_MAINTAINER_MODE
m4_ifndef([XORG_MACROS_VERSION],
[m4_fatal([must install xorg-macros 1.8 or later before running autoconf/autogen])])
XORG_MACROS_VERSION(1.8)
-
-AM_CONFIG_HEADER(config.h)
+XORG_DEFAULT_OPTIONS
AC_TYPE_SIGNAL
-XORG_DEFAULT_OPTIONS
-
# Checks for pkg-config packages
-PKG_CHECK_MODULES(XHOST, x11 xmuu xau)
+# - Both CFLAGS & LIBS needed:
+PKG_CHECK_MODULES(XHOST, x11 xmuu)
+# - Only CFLAGS needed, not libs:
+PKG_CHECK_MODULES(XAU, xau)
# Transport selection macro from xtrans.m4
XTRANS_CONNECTION_FLAGS
@@ -26,4 +31,7 @@ XTRANS_CONNECTION_FLAGS
# Secure RPC detection macro from xtrans.m4
XTRANS_SECURE_RPC_FLAGS
-AC_OUTPUT([Makefile])
+AC_CONFIG_FILES([
+ Makefile
+ man/Makefile])
+AC_OUTPUT