aboutsummaryrefslogtreecommitdiff
path: root/fontconfig/doc/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'fontconfig/doc/Makefile.am')
-rw-r--r--fontconfig/doc/Makefile.am15
1 files changed, 9 insertions, 6 deletions
diff --git a/fontconfig/doc/Makefile.am b/fontconfig/doc/Makefile.am
index e86abe9e3..2e7363cf6 100644
--- a/fontconfig/doc/Makefile.am
+++ b/fontconfig/doc/Makefile.am
@@ -82,9 +82,9 @@ DOC_FUNCS_FNCS = \
fcstrset.fncs \
fcvalue.fncs \
$(NULL)
-SGML_FILES = \
- $(srcdir)/fontconfig-user.sgml \
- $(srcdir)/fontconfig-devel.sgml \
+SGML_FILES = \
+ fontconfig-user.sgml \
+ fontconfig-devel.sgml \
$(NULL)
LOCAL_SGML_FILES = \
local-fontconfig-user.sgml \
@@ -156,7 +156,7 @@ if CROSS_COMPILING
else
.fncs.sgml:
$(AM_V_GEN) $(RM) $@; \
- $(builddir)/edit-sgml$(EXEEXT) $(srcdir)/func.sgml < '$*.fncs' > $*.sgml
+ $(builddir)/edit-sgml$(EXEEXT) $(srcdir)/func.sgml < '$(srcdir)/$*.fncs' > $*.sgml
endif
.sgml.txt:
$(AM_V_GEN) $(RM) $@; \
@@ -198,13 +198,16 @@ $(HTML_DIR): local-fontconfig-devel.sgml $(DOCS_DEPS)
$(AM_V_GEN) $(RM) -r $@; \
$(DOC2HTML) -V '%use-id-as-filename%' -o $@ local-fontconfig-devel.sgml
local-fontconfig-user.sgml: $(srcdir)/fontconfig-user.sgml
- $(AM_V_GEN) $(LN_S) $(srcdir)/fontconfig-user.sgml $@
+ $(AM_V_GEN) $(LN_S) $(srcdir)/fontconfig-user.sgml $@; \
+ [ ! -f $(builddir)/fontconfig-user.sgml ] && cp -a $(srcdir)/fontconfig-user.sgml $(builddir)/fontconfig-user.sgml || :
local-fontconfig-devel.sgml: $(srcdir)/fontconfig-devel.sgml
- $(AM_V_GEN) $(LN_S) $(srcdir)/fontconfig-devel.sgml $@
+ $(AM_V_GEN) $(LN_S) $(srcdir)/fontconfig-devel.sgml $@; \
+ [ ! -f $(builddir)/fontconfig-devel.sgml ] && cp -a $(srcdir)/fontconfig-devel.sgml $(builddir)/fontconfig-devel.sgml || :
#
all-local: $(BUILT_DOCS) $(HTML_DIR)/*
clean-local:
$(RM) -r $(HTML_DIR) devel-man
+ [ "x$(builddir)" != "x$(srcdir)" ] && $(RM) $(builddir)/fontconfig-user.sgml $(builddir)/fontconfig-devel.sgml || :
else
htmldoc_DATA += $(srcdir)/$(HTML_DIR)/*
all-local: