aboutsummaryrefslogtreecommitdiff
path: root/fontconfig/test/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'fontconfig/test/Makefile.am')
-rw-r--r--fontconfig/test/Makefile.am11
1 files changed, 11 insertions, 0 deletions
diff --git a/fontconfig/test/Makefile.am b/fontconfig/test/Makefile.am
index 3fd343a24..664138a5b 100644
--- a/fontconfig/test/Makefile.am
+++ b/fontconfig/test/Makefile.am
@@ -4,6 +4,17 @@ TESTS=run-test.sh
TESTDATA=4x6.pcf 8x16.pcf out.expected fonts.conf.in
+AM_CPPFLAGS = -I$(top_srcdir) -I$(top_builddir)
+
+if HAVE_PTHREAD
+check_PROGRAMS = test-pthread
+noinst_PROGRAMS = $(check_PROGRAMS)
+test_pthread_LDADD = $(top_builddir)/src/libfontconfig.la
+# We don't enable this test by default because it will require config and fonts
+# to meaningfully test anything, and we are not installed yet.
+#TESTS += test-pthread
+endif
+
EXTRA_DIST=$(check_SCRIPTS) $(TESTDATA)
CLEANFILES=