aboutsummaryrefslogtreecommitdiff
path: root/libXaw/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'libXaw/configure.ac')
-rw-r--r--libXaw/configure.ac11
1 files changed, 10 insertions, 1 deletions
diff --git a/libXaw/configure.ac b/libXaw/configure.ac
index 3ed625e7d..1cbe86646 100644
--- a/libXaw/configure.ac
+++ b/libXaw/configure.ac
@@ -1,7 +1,7 @@
# Initialize Autoconf
AC_PREREQ([2.60])
-AC_INIT([libXaw], [1.0.11],
+AC_INIT([libXaw], [1.0.12],
[https://bugs.freedesktop.org/enter_bug.cgi?product=xorg], [libXaw])
AC_CONFIG_SRCDIR([Makefile.am])
AC_CONFIG_HEADERS([config.h])
@@ -98,6 +98,15 @@ AC_CHECK_HEADERS([wctype.h wchar.h widec.h])
# Checks for functions
AC_CHECK_FUNCS([iswalnum getpagesize])
+# Link with winsock if mingw target
+case $host_os in
+ *mingw*)
+ AC_CHECK_LIB([ws2_32],[main])
+ ;;
+ *)
+ ;;
+esac
+
AC_CONFIG_FILES([Makefile
include/Makefile
man/Makefile