aboutsummaryrefslogtreecommitdiff
path: root/libXdmcp/test/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'libXdmcp/test/Makefile.am')
-rw-r--r--libXdmcp/test/Makefile.am13
1 files changed, 13 insertions, 0 deletions
diff --git a/libXdmcp/test/Makefile.am b/libXdmcp/test/Makefile.am
new file mode 100644
index 000000000..d86719ed4
--- /dev/null
+++ b/libXdmcp/test/Makefile.am
@@ -0,0 +1,13 @@
+if ENABLE_UNIT_TESTS
+
+check_PROGRAMS = Array
+
+TESTS=$(check_PROGRAMS)
+
+AM_CFLAGS = $(CWARNFLAGS) $(XDMCP_CFLAGS)
+AM_CPPFLAGS = -I$(top_srcdir)/include
+LDADD= $(top_builddir)/libXdmcp.la $(XDMCP_LIBS)
+
+AM_TESTS_ENVIRONMENT = $(XORG_MALLOC_DEBUG_ENV)
+
+endif ENABLE_UNIT_TESTS