aboutsummaryrefslogtreecommitdiff
path: root/libXinerama/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'libXinerama/configure.ac')
-rw-r--r--libXinerama/configure.ac8
1 files changed, 7 insertions, 1 deletions
diff --git a/libXinerama/configure.ac b/libXinerama/configure.ac
index e3355083b..17c5cb1fd 100644
--- a/libXinerama/configure.ac
+++ b/libXinerama/configure.ac
@@ -21,7 +21,7 @@
# Initialize Autoconf
AC_PREREQ([2.60])
-AC_INIT([libXinerama], [1.1.2],
+AC_INIT([libXinerama], [1.1.3],
[https://bugs.freedesktop.org/enter_bug.cgi?product=xorg], [libXinerama])
AC_CONFIG_SRCDIR([Makefile.am])
AC_CONFIG_HEADERS([config.h])
@@ -42,6 +42,12 @@ XORG_CHECK_MALLOC_ZERO
# Obtain compiler/linker options for depedencies
PKG_CHECK_MODULES(XINERAMA, x11 xext xextproto [xineramaproto >= 1.1.99.1])
+# Check for _XEatDataWords function that may be patched into older Xlib releases
+SAVE_LIBS="$LIBS"
+LIBS="$XINERAMA_LIBS"
+AC_CHECK_FUNCS([_XEatDataWords])
+LIBS="$SAVE_LIBS"
+
# Allow checking code with lint, sparse, etc.
XORG_WITH_LINT
LINT_FLAGS="${LINT_FLAGS} ${XINERAMA_CFLAGS}"