aboutsummaryrefslogtreecommitdiff
path: root/libXmu/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'libXmu/Makefile.am')
-rw-r--r--libXmu/Makefile.am24
1 files changed, 24 insertions, 0 deletions
diff --git a/libXmu/Makefile.am b/libXmu/Makefile.am
new file mode 100644
index 000000000..955bcb9e2
--- /dev/null
+++ b/libXmu/Makefile.am
@@ -0,0 +1,24 @@
+SUBDIRS = include src
+
+pkgconfigdir = $(libdir)/pkgconfig
+pkgconfig_DATA = xmu.pc xmuu.pc
+
+EXTRA_DIST = \
+ xmu.pc.in \
+ xmuu.pc.in \
+ include/X11/Xmu/WhitePoint.h \
+ ChangeLog
+MAINTAINERCLEANFILES = ChangeLog
+
+.PHONY: ChangeLog
+
+ChangeLog:
+ $(CHANGELOG_CMD)
+
+dist-hook: ChangeLog
+
+if LINT
+# Check source code with tools like lint & sparse
+lint:
+ (cd src && $(MAKE) $(MFLAGS) lint)
+endif LINT