aboutsummaryrefslogtreecommitdiff
path: root/libXpm/src/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'libXpm/src/Makefile.am')
-rw-r--r--libXpm/src/Makefile.am46
1 files changed, 46 insertions, 0 deletions
diff --git a/libXpm/src/Makefile.am b/libXpm/src/Makefile.am
new file mode 100644
index 000000000..0c8652a8f
--- /dev/null
+++ b/libXpm/src/Makefile.am
@@ -0,0 +1,46 @@
+# Daniel Stone disowns all copyright on this file.
+
+lib_LTLIBRARIES=libXpm.la
+
+AM_CPPFLAGS = -I. -I$(top_srcdir)/include/X11/
+AM_CFLAGS = $(CWARNFLAGS) $(XPM_CFLAGS)
+
+libXpm_la_LDFLAGS = -version-number 4:11:0 -no-undefined
+libXpm_la_LIBADD = $(XPM_LIBS)
+
+libXpm_la_SOURCES = \
+ Attrib.c \
+ CrBufFrI.c \
+ CrBufFrP.c \
+ CrDatFrI.c \
+ CrDatFrP.c \
+ CrIFrBuf.c \
+ CrIFrDat.c \
+ CrIFrP.c \
+ CrPFrBuf.c \
+ CrPFrDat.c \
+ CrPFrI.c \
+ Image.c \
+ Info.c \
+ RdFToBuf.c \
+ RdFToDat.c \
+ RdFToI.c \
+ RdFToP.c \
+ WrFFrBuf.c \
+ WrFFrDat.c \
+ WrFFrI.c \
+ WrFFrP.c \
+ XpmI.h \
+ create.c \
+ data.c \
+ hashtab.c \
+ misc.c \
+ parse.c \
+ rgb.c \
+ rgbtab.h \
+ scan.c
+
+libXpmincludedir = $(includedir)/X11
+libXpminclude_HEADERS = $(top_srcdir)/include/X11/xpm.h
+
+EXTRA_DIST = amigax.c amigax.h simx.c simx.h