aboutsummaryrefslogtreecommitdiff
path: root/libXpm/sxpm/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'libXpm/sxpm/Makefile.am')
-rw-r--r--libXpm/sxpm/Makefile.am25
1 files changed, 4 insertions, 21 deletions
diff --git a/libXpm/sxpm/Makefile.am b/libXpm/sxpm/Makefile.am
index faa192c37..8241e871e 100644
--- a/libXpm/sxpm/Makefile.am
+++ b/libXpm/sxpm/Makefile.am
@@ -2,13 +2,12 @@ if BUILD_SXPM
bin_PROGRAMS = sxpm
+AM_CPPFLAGS = -I$(top_srcdir)/include
AM_CFLAGS = $(CWARNFLAGS) $(SXPM_CFLAGS)
-AM_CPPFLAGS = -I$(top_srcdir)/include -I$(top_builddir)/include
-
sxpm_SOURCES = sxpm.c
-sxpm_LDADD = $(XPM_LIBS) $(SXPM_LIBS) $(top_builddir)/src/libXpm.la
+LDADD = $(SXPM_LIBS) $(top_builddir)/src/libXpm.la
# Man page
appmandir = $(APP_MAN_DIR)
@@ -18,27 +17,11 @@ appman_DATA = $(appman_PRE:man=@APP_MAN_SUFFIX@)
CLEANFILES = $(appman_DATA)
-# Strings to replace in man pages
-XORGRELSTRING = @PACKAGE_STRING@
- XORGMANNAME = X Version 11
-
-MAN_SUBSTS = \
- -e 's|__vendorversion__|"$(XORGRELSTRING)" "$(XORGMANNAME)"|' \
- -e 's|__xorgversion__|"$(XORGRELSTRING)" "$(XORGMANNAME)"|' \
- -e 's|__xservername__|Xorg|g' \
- -e 's|__xconfigfile__|xorg.conf|g' \
- -e 's|__projectroot__|$(prefix)|g' \
- -e 's|__apploaddir__|$(appdefaultdir)|' \
- -e 's|__appmansuffix__|$(APP_MAN_SUFFIX)|g' \
- -e 's|__libmansuffix__|$(LIB_MAN_SUFFIX)|g' \
- -e 's|__adminmansuffix__|$(ADMIN_MAN_SUFFIX)|g' \
- -e 's|__miscmansuffix__|$(MISC_MAN_SUFFIX)|g' \
- -e 's|__filemansuffix__|$(FILE_MAN_SUFFIX)|g'
-
SUFFIXES = .$(APP_MAN_SUFFIX) .man
+# String replacements in MAN_SUBSTS now come from xorg-macros.m4 via configure
.man.$(APP_MAN_SUFFIX):
- $(AM_V_GEN)sed $(MAN_SUBSTS) < $< > $@
+ $(AM_V_GEN)$(SED) $(MAN_SUBSTS) < $< > $@
if USE_GETTEXT
noinst_DATA = sxpm.po