aboutsummaryrefslogtreecommitdiff
path: root/libXt/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'libXt/configure.ac')
-rw-r--r--libXt/configure.ac46
1 files changed, 41 insertions, 5 deletions
diff --git a/libXt/configure.ac b/libXt/configure.ac
index 96f0ccb17..d15b32699 100644
--- a/libXt/configure.ac
+++ b/libXt/configure.ac
@@ -22,7 +22,7 @@
# Initialize Autoconf
AC_PREREQ([2.60])
-AC_INIT([libXt], [1.1.1],
+AC_INIT([libXt], [1.1.3],
[https://bugs.freedesktop.org/enter_bug.cgi?product=xorg], [libXt])
AC_CONFIG_SRCDIR([Makefile.am])
AC_CONFIG_HEADERS([config.h])
@@ -35,12 +35,20 @@ AM_MAINTAINER_MODE
# Initialize libtool
AC_PROG_LIBTOOL
-# Require X.Org macros 1.8 or later for MAN_SUBSTS set by XORG_MANPAGE_SECTIONS
+# Require X.Org macros 1.13 or later for XORG_ENABLE_UNIT_TESTS
m4_ifndef([XORG_MACROS_VERSION],
- [m4_fatal([must install xorg-macros 1.8 or later before running autoconf/autogen])])
-XORG_MACROS_VERSION(1.8)
+ [m4_fatal([must install xorg-macros 1.13 or later before running autoconf/autogen])])
+XORG_MACROS_VERSION(1.13)
XORG_DEFAULT_OPTIONS
XORG_CHECK_MALLOC_ZERO
+XORG_ENABLE_SPECS
+XORG_WITH_XMLTO(0.0.20)
+XORG_WITH_FOP
+XORG_WITH_XSLTPROC
+XORG_CHECK_SGML_DOCTOOLS(1.01)
+XORG_PROG_RAWCPP
+XORG_WITH_PERL
+
# Checks for header files.
AC_CHECK_HEADER([alloca.h], AC_DEFINE(INCLUDE_ALLOCA_H, 1, [Define to 1 if Xalloca.h should include <alloca.h>]))
@@ -86,7 +94,14 @@ case $host_os in
;;
esac
-AC_HAVE_LIBRARY(ws2_32)
+# Link with winsock if mingw target
+case $host_os in
+ *mingw*)
+ AC_HAVE_LIBRARY(ws2_32)
+ ;;
+ *)
+ ;;
+esac
# Options
AC_ARG_ENABLE(xkb, AS_HELP_STRING([--disable-xkb], [Disable XKB support]),
@@ -95,6 +110,26 @@ if test "x$XKB" = "xyes" ; then
AC_DEFINE(XKB, 1, [Define to 1 to use XKB for keysym resolution.])
fi
+# --enable-unit-tests
+XORG_ENABLE_UNIT_TESTS
+XORG_WITH_GLIB([2.16])
+
+# Memory checking support
+case $host_os in
+ solaris*)
+ AC_CHECK_LIB([umem], [umem_alloc],
+ [MALLOC_DEBUG_ENV='LD_PRELOAD=libumem.so UMEM_DEBUG=default'])
+ ;;
+ *-gnu*) # GNU libc - Value is used as a single byte bit pattern,
+ # both directly and inverted, so should not be 0 or 255.
+ MALLOC_DEBUG_ENV='MALLOC_PERTURB_=15'
+ ;;
+ *bsd*|darwin*)
+ MALLOC_DEBUG_ENV='MallocPreScribble=1 MallocScribble=1'
+ ;;
+esac
+AC_SUBST([MALLOC_DEBUG_ENV])
+
# Replaces XFileSearchPathDefault from Imake configs
XFILESEARCHPATHDEFAULT='$(sysconfdir)/X11/%L/%T/%N%C%S:$(sysconfdir)/X11/%l/%T/%N%C%S:$(sysconfdir)/X11/%T/%N%C%S:$(sysconfdir)/X11/%L/%T/%N%S:$(sysconfdir)/X11/%l/%T/%N%S:$(sysconfdir)/X11/%T/%N%S:$(datadir)/X11/%L/%T/%N%C%S:$(datadir)/X11/%l/%T/%N%C%S:$(datadir)/X11/%T/%N%C%S:$(datadir)/X11/%L/%T/%N%S:$(datadir)/X11/%l/%T/%N%S:$(datadir)/X11/%T/%N%S:$(libdir)/X11/%L/%T/%N%C%S:$(libdir)/X11/%l/%T/%N%C%S:$(libdir)/X11/%T/%N%C%S:$(libdir)/X11/%L/%T/%N%S:$(libdir)/X11/%l/%T/%N%S:$(libdir)/X11/%T/%N%S'
@@ -144,5 +179,6 @@ AC_CONFIG_FILES([Makefile
include/Makefile
man/Makefile
specs/Makefile
+ test/Makefile
xt.pc])
AC_OUTPUT