aboutsummaryrefslogtreecommitdiff
path: root/libXt/specs/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'libXt/specs/Makefile.am')
-rw-r--r--libXt/specs/Makefile.am61
1 files changed, 37 insertions, 24 deletions
diff --git a/libXt/specs/Makefile.am b/libXt/specs/Makefile.am
index 887eb7e1e..c922dbb8e 100644
--- a/libXt/specs/Makefile.am
+++ b/libXt/specs/Makefile.am
@@ -1,24 +1,37 @@
-EXTRA_DIST = \
- CH01 \
- CH02 \
- CH03 \
- CH04 \
- CH05 \
- CH06 \
- CH07 \
- CH08 \
- CH09 \
- CH10 \
- CH11 \
- CH12 \
- CH13 \
- appA \
- appB \
- appC \
- appD \
- appE \
- appF \
- intr.idxmac.t \
- postproc \
- strings.mit \
- Xtk.intr.front
+
+if ENABLE_SPECS
+
+# Main DocBook/XML files (DOCTYPE book)
+docbook = intrinsics.xml
+
+# Included chapters, appendix, images
+chapters = \
+ acknowledgement.xml \
+ preface.xml \
+ CH01.xml \
+ CH02.xml \
+ CH03.xml \
+ CH04.xml \
+ CH05.xml \
+ CH06.xml \
+ CH07.xml \
+ CH08.xml \
+ CH09.xml \
+ CH10.xml \
+ CH11.xml \
+ CH12.xml \
+ CH13.xml \
+ appA.xml \
+ appB.xml \
+ appC.xml \
+ appD.xml \
+ appE.xml \
+ appF.xml
+
+# The location where the DocBook/XML files and their generated formats are installed
+shelfdir = $(docdir)
+
+# Generate DocBook/XML output formats with or without stylesheets
+include $(top_srcdir)/docbook.am
+
+endif ENABLE_SPECS