aboutsummaryrefslogtreecommitdiff
path: root/libXt/test/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'libXt/test/Makefile.am')
-rw-r--r--libXt/test/Makefile.am14
1 files changed, 14 insertions, 0 deletions
diff --git a/libXt/test/Makefile.am b/libXt/test/Makefile.am
new file mode 100644
index 000000000..7494c4147
--- /dev/null
+++ b/libXt/test/Makefile.am
@@ -0,0 +1,14 @@
+if ENABLE_UNIT_TESTS
+if HAVE_GLIB
+check_PROGRAMS = Alloc Converters Event
+
+TESTS=$(check_PROGRAMS)
+
+AM_CFLAGS = $(CWARNFLAGS) $(XT_CFLAGS) $(GLIB_CFLAGS)
+INCLUDES = -I$(top_srcdir)/include -I$(top_builddir)/include
+LDADD= $(top_builddir)/src/libXt.la $(GLIB_LIBS)
+
+TESTS_ENVIRONMENT = $(MALLOC_DEBUG_ENV)
+
+endif HAVE_GLIB
+endif ENABLE_UNIT_TESTS