aboutsummaryrefslogtreecommitdiff
path: root/mesalib/src/glsl/builtin_compiler/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'mesalib/src/glsl/builtin_compiler/Makefile.am')
-rw-r--r--mesalib/src/glsl/builtin_compiler/Makefile.am36
1 files changed, 14 insertions, 22 deletions
diff --git a/mesalib/src/glsl/builtin_compiler/Makefile.am b/mesalib/src/glsl/builtin_compiler/Makefile.am
index d27aca555..1a863b228 100644
--- a/mesalib/src/glsl/builtin_compiler/Makefile.am
+++ b/mesalib/src/glsl/builtin_compiler/Makefile.am
@@ -40,31 +40,23 @@ AM_CFLAGS = \
AM_CXXFLAGS = $(AM_CFLAGS)
-AM_YFLAGS = -v -d -p "glcpp_parser_"
-AM_LFLAGS = --nounistd -o$(LEX_OUTPUT_ROOT).c
-
include ../Makefile.sources
noinst_PROGRAMS = builtin_compiler
+noinst_LTLIBRARIES = libglslcore.la libglcpp.la
-builtin_compiler_SOURCES = \
- $(GLSL_SRCDIR)/glcpp/glcpp-lex.l \
- $(GLSL_SRCDIR)/glcpp/glcpp-parse.y \
- $(LIBGLCPP_FILES) \
- $(GLSL_SRCDIR)/glsl_lexer.ll \
- $(GLSL_BUILDDIR)/glsl_parser.cc \
- $(LIBGLSL_FILES) \
- $(LIBGLSL_CXX_FILES) \
- $(top_srcdir)/src/mesa/main/hash_table.c \
- $(top_srcdir)/src/mesa/program/prog_hash_table.c \
- $(top_srcdir)/src/mesa/program/symbol_table.c \
- $(GLSL_COMPILER_CXX_FILES) \
- builtin_stubs.cpp
+libglcpp_la_SOURCES = \
+ $(LIBGLCPP_GENERATED_FILES) \
+ $(LIBGLCPP_FILES)
-BUILT_SOURCES = \
- glcpp-lex.c \
- glcpp-parse.c \
- glcpp-parse.h \
- glsl_lexer.cc
+libglslcore_la_SOURCES = \
+ $(BUILTIN_COMPILER_GENERATED_CXX_FILES) \
+ $(LIBGLSL_FILES)
-CLEANFILES = $(BUILT_SOURCES)
+builtin_compiler_SOURCES = \
+ $(top_srcdir)/src/mesa/main/hash_table.c \
+ $(top_srcdir)/src/mesa/program/prog_hash_table.c\
+ $(top_srcdir)/src/mesa/program/symbol_table.c \
+ $(BUILTIN_COMPILER_CXX_FILES) \
+ $(GLSL_COMPILER_CXX_FILES)
+builtin_compiler_LDADD = libglslcore.la libglcpp.la