aboutsummaryrefslogtreecommitdiff
path: root/tools/bison++/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'tools/bison++/Makefile.am')
-rw-r--r--tools/bison++/Makefile.am49
1 files changed, 49 insertions, 0 deletions
diff --git a/tools/bison++/Makefile.am b/tools/bison++/Makefile.am
new file mode 100644
index 000000000..b25b23b2f
--- /dev/null
+++ b/tools/bison++/Makefile.am
@@ -0,0 +1,49 @@
+bin_PROGRAMS = bison++
+AUTOMAKE_OPTIONS = foreign
+
+bison___SOURCES = closure.cc \
+ derives.cc \
+ getargs.cc \
+ getopt1.cc \
+ lalr.cc \
+ lr0.cc \
+ nullable.cc \
+ print.cc \
+ reduce.cc \
+ version.cc \
+ warshall.cc \
+ allocate.cc \
+ conflict.cc \
+ files.cc \
+ getopt.cc \
+ gram.cc \
+ lex.cc \
+ main.cc \
+ output.cc \
+ reader.cc \
+ symtab.cc\
+ old.c
+
+info_TEXINFOS = bison.texinfo
+man_MANS = bison++.1 bison.1 bison++.yacc.1
+pkgdata_DATA = bison.cc bison.hairy bison.h Example
+CXX=g++
+PFILE = bison.cc
+PFILE1 = bison.hairy
+HFILE = bison.h
+INCLUDES = -DXPFILE=\"$(datadir)/bison++/$(PFILE)\" \
+ -DXHFILE=\"$(datadir)/bison++/$(HFILE)\" \
+ -DXPFILE1=\"$(datadir)/bison++/$(PFILE1)\"
+
+install-exec-hook:
+ cp bison $(bindir)
+ cp bison++.yacc $(bindir)
+
+uninstall-hook:
+ rm $(bindir)/bison++.yacc
+ rm $(bindir)/bison
+
+
+
+
+