aboutsummaryrefslogtreecommitdiff
path: root/xkbcomp/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'xkbcomp/Makefile.am')
-rw-r--r--xkbcomp/Makefile.am4
1 files changed, 2 insertions, 2 deletions
diff --git a/xkbcomp/Makefile.am b/xkbcomp/Makefile.am
index ffcbcbde3..fca1f6700 100644
--- a/xkbcomp/Makefile.am
+++ b/xkbcomp/Makefile.am
@@ -21,7 +21,7 @@
bin_PROGRAMS = xkbcomp
-AM_CFLAGS = $(XKBCOMP_CFLAGS) -DDFLT_XKB_CONFIG_ROOT='"$(datadir)/X11/xkb"'
+AM_CFLAGS = $(XKBCOMP_CFLAGS) -DDFLT_XKB_CONFIG_ROOT='"$(XKBCONFIGROOT)"'
xkbcomp_LDADD = $(XKBCOMP_LIBS)
xkbcomp_SOURCES = \
@@ -105,6 +105,6 @@ MAINTAINERCLEANFILES += ChangeLog
.PHONY: ChangeLog
ChangeLog:
- (GIT_DIR=$(top_srcdir)/.git git-log > .changelog.tmp && mv .changelog.tmp ChangeLog; rm -f .changelog.tmp) || (touch ChangeLog; echo 'git directory not found: installing possibly empty changelog.' >&2)
+ $(CHANGELOG_CMD)
dist-hook: ChangeLog