aboutsummaryrefslogtreecommitdiff
path: root/xkbcomp/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'xkbcomp/configure.ac')
-rw-r--r--xkbcomp/configure.ac7
1 files changed, 5 insertions, 2 deletions
diff --git a/xkbcomp/configure.ac b/xkbcomp/configure.ac
index 81ec27b2f..fb71294c0 100644
--- a/xkbcomp/configure.ac
+++ b/xkbcomp/configure.ac
@@ -20,9 +20,14 @@ dnl PERFORMANCE OF THIS SOFTWARE.
dnl
dnl Process this file with autoconf to create configure.
+# Initialize Autoconf
AC_PREREQ([2.60])
AC_INIT([xkbcomp], [1.2.4],
[https://bugs.freedesktop.org/enter_bug.cgi?product=xorg], [xkbcomp])
+AC_CONFIG_SRCDIR([Makefile.am])
+AC_CONFIG_HEADERS([config.h])
+
+# Initialize Automake
AM_INIT_AUTOMAKE([foreign dist-bzip2])
# Require X.Org macros 1.8 or later for MAN_SUBSTS set by XORG_MANPAGE_SECTIONS
@@ -31,8 +36,6 @@ m4_ifndef([XORG_MACROS_VERSION],
XORG_MACROS_VERSION(1.8)
XORG_DEFAULT_OPTIONS
-AC_CONFIG_HEADERS([config.h])
-
# If both the C file and YACC are missing, the package cannot be build.
AC_PROG_YACC
AC_PATH_PROG([YACC_INST], $YACC)