aboutsummaryrefslogtreecommitdiff
path: root/xorg-server/doc/man/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'xorg-server/doc/man/Makefile.am')
-rw-r--r--xorg-server/doc/man/Makefile.am20
1 files changed, 20 insertions, 0 deletions
diff --git a/xorg-server/doc/man/Makefile.am b/xorg-server/doc/man/Makefile.am
new file mode 100644
index 000000000..5259a104f
--- /dev/null
+++ b/xorg-server/doc/man/Makefile.am
@@ -0,0 +1,20 @@
+# Xserver.man covers options generic to all X servers built in this tree
+# (i.e. those handled in the os/utils.c options processing instead of in
+# the DDX-level options processing)
+
+appmandir = $(APP_MAN_DIR)
+appman_PRE = Xserver.man
+appman_DATA = $(appman_PRE:man=$(APP_MAN_SUFFIX))
+
+EXTRA_DIST = $(appman_PRE)
+CLEANFILES = $(appman_DATA)
+SUFFIXES = .$(APP_MAN_SUFFIX) .man
+
+# String replacements in MAN_SUBSTS now come from xorg-macros.m4 via configure
+# 's|/,|/, |g' will add a space to help font path formatting
+MAN_SUBSTS += -e 's|__datadir__|$(datadir)|g' \
+ -e 's|__default_font_path__|$(COMPILEDDEFAULTFONTPATH)|g' \
+ -e '\|$(COMPILEDDEFAULTFONTPATH)| s|/,|/, |g'
+
+.man.$(APP_MAN_SUFFIX):
+ $(AM_V_GEN)$(SED) $(MAN_SUBSTS) < $< > $@