aboutsummaryrefslogtreecommitdiff
path: root/xorg-server/hw/xquartz/mach-startup/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'xorg-server/hw/xquartz/mach-startup/Makefile.am')
-rw-r--r--xorg-server/hw/xquartz/mach-startup/Makefile.am14
1 files changed, 8 insertions, 6 deletions
diff --git a/xorg-server/hw/xquartz/mach-startup/Makefile.am b/xorg-server/hw/xquartz/mach-startup/Makefile.am
index 21ad5b503..77962b14d 100644
--- a/xorg-server/hw/xquartz/mach-startup/Makefile.am
+++ b/xorg-server/hw/xquartz/mach-startup/Makefile.am
@@ -23,7 +23,7 @@ nodist_X11_bin_SOURCES = \
mach_startupServer.c \
mach_startupUser.c
-X11_bin_LDADD = \
+X11_bin_DEPENDENCIES = \
$(top_builddir)/hw/xquartz/libXquartz.la \
$(top_builddir)/hw/xquartz/xpr/libXquartzXpr.la \
$(top_builddir)/dix/dixfonts.lo \
@@ -31,8 +31,12 @@ X11_bin_LDADD = \
$(top_builddir)/hw/xquartz/pbproxy/libxpbproxy.la \
$(XQUARTZ_LIBS) $(XSERVER_LIBS)
+# $(XSERVER_SYS_LIBS) is placed here in order to set command line ordering
+# to work around build issues on Tiger.
+X11_bin_LDADD = $(X11_bin_DEPENDENCIES) $(XSERVER_SYS_LIBS)
+
X11_bin_LDFLAGS = \
- $(XSERVER_SYS_LIBS) -lXplugin \
+ -lXplugin \
-XCClinker -Objc \
-Wl,-u,_miDCInitialize \
-Wl,-framework,Carbon \
@@ -41,7 +45,7 @@ X11_bin_LDFLAGS = \
-Wl,-framework,IOKit
if GLX
-X11_bin_LDADD += \
+X11_bin_DEPENDENCIES += \
$(top_builddir)/hw/xquartz/GL/libCGLCore.la \
$(top_builddir)/glx/libglx.la
@@ -55,12 +59,10 @@ X11_bin_LDFLAGS += \
endif
if RECORD
-X11_bin_LDADD += \
+X11_bin_DEPENDENCIES += \
$(top_builddir)/record/librecord.la
endif
-X11_bin_DEPENDENCIES = $(X11_bin_LDADD)
-
bin_PROGRAMS = Xquartz
dist_Xquartz_SOURCES = \