aboutsummaryrefslogtreecommitdiff
path: root/xorg-server/hw/xquartz/pbproxy/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'xorg-server/hw/xquartz/pbproxy/Makefile.am')
-rw-r--r--xorg-server/hw/xquartz/pbproxy/Makefile.am23
1 files changed, 23 insertions, 0 deletions
diff --git a/xorg-server/hw/xquartz/pbproxy/Makefile.am b/xorg-server/hw/xquartz/pbproxy/Makefile.am
new file mode 100644
index 000000000..e1c537fbb
--- /dev/null
+++ b/xorg-server/hw/xquartz/pbproxy/Makefile.am
@@ -0,0 +1,23 @@
+AM_CPPFLAGS=-F/System/Library/Frameworks/ApplicationServices.framework/Frameworks
+AM_CFLAGS=$(XPBPROXY_CFLAGS)
+
+noinst_LTLIBRARIES = libxpbproxy.la
+libxpbproxy_la_SOURCES = \
+ trick_autotools.c \
+ main.m \
+ x-input.m \
+ x-selection.m
+
+libxpbproxy_la_LDFLAGS=$(XPBPROXY_LIBS)
+
+if STANDALONE_XPBPROXY
+
+bin_PROGRAMS = xpbproxy
+xpbproxy_SOURCES = app-main.m
+xpbproxy_LDADD = libxpbproxy.la
+
+endif
+
+EXTRA_DIST = \
+ pbproxy.h \
+ x-selection.h