aboutsummaryrefslogtreecommitdiff
path: root/xorg-server/os/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'xorg-server/os/Makefile.am')
-rw-r--r--xorg-server/os/Makefile.am17
1 files changed, 12 insertions, 5 deletions
diff --git a/xorg-server/os/Makefile.am b/xorg-server/os/Makefile.am
index 66a4a0f75..3e4f2c591 100644
--- a/xorg-server/os/Makefile.am
+++ b/xorg-server/os/Makefile.am
@@ -1,11 +1,19 @@
-noinst_LTLIBRARIES = libos.la
+noinst_LTLIBRARIES = libos.la liblog.la
AM_CFLAGS = $(DIX_CFLAGS) $(SHA1_CFLAGS)
SECURERPC_SRCS = rpcauth.c
XDMCP_SRCS = xdmcp.c
STRLCAT_SRCS = strlcat.c strlcpy.c
-XORG_SRCS = log.c
+
+# Build a convenience library liblog.la that will be added into
+# libos.la. The split is done so that log.c can be built with
+# different compiler options.
+liblog_la_SOURCES = log.c
+# Add flags needed for proper backtraces of functions marked with GCC
+# __attribute__((noreturn)). Currently those flags are needed for
+# FatalError and AbortServer in log.c.
+liblog_la_CFLAGS = $(AM_CFLAGS) $(ARM_BACKTRACE_CFLAGS)
libos_la_SOURCES = \
WaitFor.c \
@@ -24,9 +32,8 @@ libos_la_SOURCES = \
xdmauth.c \
xsha1.c \
xstrans.c \
- xprintf.c \
- $(XORG_SRCS)
-libos_la_LIBADD = @SHA1_LIBS@ $(DLOPEN_LIBS)
+ xprintf.c
+libos_la_LIBADD = @SHA1_LIBS@ $(DLOPEN_LIBS) liblog.la
if SECURE_RPC
libos_la_SOURCES += $(SECURERPC_SRCS)