aboutsummaryrefslogtreecommitdiff
path: root/xorg-server/test/xi2/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'xorg-server/test/xi2/Makefile.am')
-rw-r--r--xorg-server/test/xi2/Makefile.am10
1 files changed, 10 insertions, 0 deletions
diff --git a/xorg-server/test/xi2/Makefile.am b/xorg-server/test/xi2/Makefile.am
index b15d8ba02..c6e93e78f 100644
--- a/xorg-server/test/xi2/Makefile.am
+++ b/xorg-server/test/xi2/Makefile.am
@@ -13,6 +13,7 @@ noinst_PROGRAMS = \
protocol-eventconvert
TESTS=$(noinst_PROGRAMS)
+TESTS_ENVIRONMENT = $(XORG_MALLOC_DEBUG_ENV)
AM_CFLAGS = $(DIX_CFLAGS) @XORG_CFLAGS@
INCLUDES = @XORG_INCS@
@@ -53,5 +54,14 @@ protocol_xigetclientpointer_SOURCES=$(COMMON_SOURCES) protocol-xigetclientpointe
protocol_xiquerypointer_SOURCES=$(COMMON_SOURCES) protocol-xiquerypointer.c
protocol_xipassivegrabdevice_SOURCES=$(COMMON_SOURCES) protocol-xipassivegrabdevice.c
protocol_xiwarppointer_SOURCES=$(COMMON_SOURCES) protocol-xiwarppointer.c
+else
+# Print that xi2-tests were skipped (exit code 77 for automake test harness)
+TESTS = xi2-tests
+CLEANFILES = $(TESTS)
+
+xi2-tests:
+ @echo 'echo "ld -wrap support required for xi2 unit tests, skipping"' > $@
+ @echo 'exit 77' >> $@
+ $(AM_V_GEN)chmod +x $@
endif
endif