aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorCharles Kerr <charles.kerr@canonical.com>2012-04-26 22:15:10 -0500
committerCharles Kerr <charles.kerr@canonical.com>2012-04-26 22:15:10 -0500
commit2a3f56b5168e9745547d2289c0710ae606920cde (patch)
treed61e3982c09c776a7519be6a028feb4e1cf80af2 /configure.ac
parentceb09d1a5aa9f8659765a11f37c2778058d218ab (diff)
parent4636768621434e40918be355637ab6e1920ef2ba (diff)
downloadayatana-ido-2a3f56b5168e9745547d2289c0710ae606920cde.tar.gz
ayatana-ido-2a3f56b5168e9745547d2289c0710ae606920cde.tar.bz2
ayatana-ido-2a3f56b5168e9745547d2289c0710ae606920cde.zip
merge lp:~ted/ido/gtest to add the gtest framework and a few tests to make sure our menu items can be created and realized.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 8 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index c7b4864..6e350b9 100644
--- a/configure.ac
+++ b/configure.ac
@@ -57,6 +57,7 @@ dnl ===========================================================================
# Checks for programs
AC_PROG_CC
AM_PROG_CC_C_O
+AC_PROG_CXX
# Initialize libtool
LT_PREREQ([2.2])
@@ -128,6 +129,12 @@ AC_SUBST(COVERAGE_CFLAGS)
AC_SUBST(COVERAGE_CXXFLAGS)
AC_SUBST(COVERAGE_LDFLAGS)
+dnl = Google Test Framework ===================================================
+
+m4_include([m4/gtest.m4])
+CHECK_GTEST
+CHECK_XORG_GTEST
+
dnl = GTK Doc Check ===========================================================
GTK_DOC_CHECK([1.8])
@@ -138,6 +145,7 @@ AC_CONFIG_FILES([
Makefile
src/Makefile
example/Makefile
+ tests/Makefile
libido.pc
libido3.pc
])