aboutsummaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
authorMike Gabriel <mike.gabriel@das-netzwerkteam.de>2021-04-21 22:12:42 +0200
committerMike Gabriel <mike.gabriel@das-netzwerkteam.de>2021-04-21 22:12:42 +0200
commitfcf633bdbc0b7d64fe1ea6005ab007f0db151c4e (patch)
tree359d2cc514826fb177cec39f6303d66649af56d4 /debian/rules
parent34e808d3b9a322db3908454944c69c1373572f66 (diff)
parent3adf9ec33ba1e5b6516dfb31f943da67926e86c7 (diff)
downloadayatana-ido-fcf633bdbc0b7d64fe1ea6005ab007f0db151c4e.tar.gz
ayatana-ido-fcf633bdbc0b7d64fe1ea6005ab007f0db151c4e.tar.bz2
ayatana-ido-fcf633bdbc0b7d64fe1ea6005ab007f0db151c4e.zip
Merge branch 'tari01-pr/switch-to-cmake'
Attributes GH PR #26: https://github.com/AyatanaIndicators/ayatana-ido/pull/26
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules16
1 files changed, 13 insertions, 3 deletions
diff --git a/debian/rules b/debian/rules
index b4a0a75..e2bd5ed 100755
--- a/debian/rules
+++ b/debian/rules
@@ -6,11 +6,18 @@ export DEB_BUILD_MAINT_OPTIONS = hardening=+all
DPKG_EXPORT_BUILDFLAGS = 1
include /usr/share/dpkg/buildflags.mk
+NULL :=
+
+DEB_CMAKE_EXTRA_FLAGS = \
+ -DENABLE_TESTS=ON \
+ -DENABLE_COVERAGE=OFF \
+ $(NULL)
+
%:
- dh $@ --with autoreconf
+ dh $@
-override_dh_autoreconf:
- NOCONFIGURE=1 dh_autoreconf ./autogen.sh
+override_dh_auto_configure:
+ dh_auto_configure -- $(DEB_CMAKE_EXTRA_FLAGS)
override_dh_install:
find debian/tmp/usr/lib -name *.la -delete
@@ -19,5 +26,8 @@ override_dh_install:
override_dh_missing:
dh_missing --fail-missing
+override_dh_auto_test:
+ xvfb-run -a dh_auto_test --no-parallel
+
get-orig-source:
uscan --noconf --force-download --rename --download-current-version --destdir=..