aboutsummaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules16
1 files changed, 13 insertions, 3 deletions
diff --git a/debian/rules b/debian/rules
index b4a0a75..e2bd5ed 100755
--- a/debian/rules
+++ b/debian/rules
@@ -6,11 +6,18 @@ export DEB_BUILD_MAINT_OPTIONS = hardening=+all
DPKG_EXPORT_BUILDFLAGS = 1
include /usr/share/dpkg/buildflags.mk
+NULL :=
+
+DEB_CMAKE_EXTRA_FLAGS = \
+ -DENABLE_TESTS=ON \
+ -DENABLE_COVERAGE=OFF \
+ $(NULL)
+
%:
- dh $@ --with autoreconf
+ dh $@
-override_dh_autoreconf:
- NOCONFIGURE=1 dh_autoreconf ./autogen.sh
+override_dh_auto_configure:
+ dh_auto_configure -- $(DEB_CMAKE_EXTRA_FLAGS)
override_dh_install:
find debian/tmp/usr/lib -name *.la -delete
@@ -19,5 +26,8 @@ override_dh_install:
override_dh_missing:
dh_missing --fail-missing
+override_dh_auto_test:
+ xvfb-run -a dh_auto_test --no-parallel
+
get-orig-source:
uscan --noconf --force-download --rename --download-current-version --destdir=..