aboutsummaryrefslogtreecommitdiff
path: root/example/CMakeLists.txt
diff options
context:
space:
mode:
authorMike Gabriel <mike.gabriel@das-netzwerkteam.de>2021-04-21 22:12:42 +0200
committerMike Gabriel <mike.gabriel@das-netzwerkteam.de>2021-04-21 22:12:42 +0200
commitfcf633bdbc0b7d64fe1ea6005ab007f0db151c4e (patch)
tree359d2cc514826fb177cec39f6303d66649af56d4 /example/CMakeLists.txt
parent34e808d3b9a322db3908454944c69c1373572f66 (diff)
parent3adf9ec33ba1e5b6516dfb31f943da67926e86c7 (diff)
downloadayatana-ido-fcf633bdbc0b7d64fe1ea6005ab007f0db151c4e.tar.gz
ayatana-ido-fcf633bdbc0b7d64fe1ea6005ab007f0db151c4e.tar.bz2
ayatana-ido-fcf633bdbc0b7d64fe1ea6005ab007f0db151c4e.zip
Merge branch 'tari01-pr/switch-to-cmake'
Attributes GH PR #26: https://github.com/AyatanaIndicators/ayatana-ido/pull/26
Diffstat (limited to 'example/CMakeLists.txt')
-rw-r--r--example/CMakeLists.txt8
1 files changed, 8 insertions, 0 deletions
diff --git a/example/CMakeLists.txt b/example/CMakeLists.txt
new file mode 100644
index 0000000..52f7bde
--- /dev/null
+++ b/example/CMakeLists.txt
@@ -0,0 +1,8 @@
+# menus
+
+set_source_files_properties(menus.c PROPERTIES COMPILE_FLAGS ${COMPILE_FLAGS})
+add_executable("menus" menus.c)
+target_include_directories("menus" PUBLIC ${PROJECT_DEPS_INCLUDE_DIRS})
+target_link_libraries("menus" ${PROJECT_DEPS_LIBRARIES} "-L${CMAKE_BINARY_DIR}/src" -layatana-ido3-0.4)
+target_include_directories("menus" PUBLIC "${CMAKE_SOURCE_DIR}/src")
+add_dependencies("menus" ayatana-ido3-0.4)