aboutsummaryrefslogtreecommitdiff
path: root/example/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'example/CMakeLists.txt')
-rw-r--r--example/CMakeLists.txt8
1 files changed, 8 insertions, 0 deletions
diff --git a/example/CMakeLists.txt b/example/CMakeLists.txt
new file mode 100644
index 0000000..52f7bde
--- /dev/null
+++ b/example/CMakeLists.txt
@@ -0,0 +1,8 @@
+# menus
+
+set_source_files_properties(menus.c PROPERTIES COMPILE_FLAGS ${COMPILE_FLAGS})
+add_executable("menus" menus.c)
+target_include_directories("menus" PUBLIC ${PROJECT_DEPS_INCLUDE_DIRS})
+target_link_libraries("menus" ${PROJECT_DEPS_LIBRARIES} "-L${CMAKE_BINARY_DIR}/src" -layatana-ido3-0.4)
+target_include_directories("menus" PUBLIC "${CMAKE_SOURCE_DIR}/src")
+add_dependencies("menus" ayatana-ido3-0.4)