aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorRobert Tari <robert@tari.in>2021-08-27 14:05:43 +0200
committerMike Gabriel <mike.gabriel@das-netzwerkteam.de>2021-08-28 14:22:15 +0200
commit3e045e899da78878f5f1da5f4d31ed05ad8aa008 (patch)
treeff6deeb31da0c4786f7ae7d522399dec04bb392a /CMakeLists.txt
parentf9dcff7b3a42082ad3ba6076991ed8aa7df9b6a8 (diff)
downloadayatana-indicator-bluetooth-3e045e899da78878f5f1da5f4d31ed05ad8aa008.tar.gz
ayatana-indicator-bluetooth-3e045e899da78878f5f1da5f4d31ed05ad8aa008.tar.bz2
ayatana-indicator-bluetooth-3e045e899da78878f5f1da5f4d31ed05ad8aa008.zip
Replace code with libayatana-common functions
- CMakeLists.txt: Add libayatana-common build dependency - src/CMakeLists.txt: Add AyatanaCommon package to ayatana-indicator-bluetooth-service - src/phone.vala: Replace local code with libayatana-common functions - src/desktop.vala: Replace local code with libayatana-common functions - vapi/lomiri-url-dispatcher.vapi: Drop file
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 2b680c1..8b526a5 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -46,6 +46,7 @@ pkg_check_modules(
BLUETOOTHSERVICE REQUIRED
glib-2.0>=${GLIB_2_0_REQUIRED_VERSION}
gio-unix-2.0>=${GIO_2_0_REQUIRED_VERSION}
+ libayatana-common>=0.9.3
)
include_directories(${BLUETOOTHSERVICE_INCLUDE_DIRS})